P0016 ?? - Volvo Forums - Volvo Enthusiasts Forum

Go Back   Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S60 & V60
Sign in using an external account
Register Forgot Password?
Search

Welcome to Volvo Forums!
Welcome to Volvo Forums,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Volvo Forums today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-13-2007, 08:17 PM
 
Join Date: Feb 2007
Posts: 6
Default P0016 ??

My check engine light recently came on. Code scanned was originaly P0011.
Cam Position Sensor was changed and now receiving P0016. Does this mean the cam sensor
was installed incorrectly? Or has the timing belt jumped a tooth?
Reply With Quote
  #2  
Old 02-17-2007, 01:13 AM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: P0016 ??

Has the timing belt been changed?
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
  #3  
Old 02-17-2007, 10:04 AM
 
Join Date: Feb 2007
Posts: 6
Default RE: P0016 ??

Timing belt is the original belt. The car has 56000 miles on it. I removed the vvt solenoid assembly and cleaned it to make sure it was not clogged. I'm planning on brining in and have a diagnostic done in a week. Is it also possible the thermostatic tensioner maybe at fault.
Reply With Quote
  #4  
Old 02-17-2007, 11:26 AM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: P0016 ??

It could be many things.
You just removed the valve mounted to the top of the engine?
The timing might be off or that valve might be sticking.
Have the Cam seals been replaced?
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
  #5  
Old 02-17-2007, 10:42 PM
 
Join Date: Feb 2007
Posts: 6
Default RE: P0016 ??

Engine has never been apart. Car was running great and then one morning started it up and had a code for a bad cam sensor. Replaced the cam sensor and now have the code P0016. Seems kind of strange that this sequence of events has happened. I'll let you know what the dealer says.

Thanks for the inside.
Reply With Quote
  #6  
Old 02-17-2007, 10:53 PM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: P0016 ??

A bad Crank sensor could do it as well.
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
  #7  
Old 02-22-2007, 10:59 AM
 
Join Date: Feb 2007
Posts: 6
Default RE: P0016 ??

I received the car back yesterday unfixed from the dealer. They game me a printout of the faults that were detected. A lot of intermittent stuff. So I guess I'm going to take a look at the timing marks myself this weekend and make sure the belt has not jumped a tooth. The printout was about five pages of every code every received. The one I'm having a problem with is 643A which according to the computer has occurred over 4000 times. So this has been an on going problem that was never resolved.
Reply With Quote
  #8  
Old 02-22-2007, 09:01 PM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: P0016 ??

Quote:
ORIGINAL: bghubr

The one I'm having a problem with is 643A which according to the computer has occurred over 4000 times. So this has been an on going problem that was never resolved.
Which one is that I don't have the info on me right now?
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
  #9  
Old 02-22-2007, 10:05 PM
 
Join Date: Feb 2007
Posts: 6
Default RE: P0016 ??

The 643A is Camshaft position exhaust signal too high. I'm not sure what that means.

Reply With Quote
  #10  
Old 02-22-2007, 10:21 PM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: P0016 ??

Yes check the timing.
You said it has a new sensor correct?
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
  #11  
Old 03-04-2007, 08:27 PM
 
Join Date: Feb 2007
Posts: 6
Default RE: P0016 ??

Just finished putting a timing belt in the car. The belt was off 2 teeth. Along with the belt I did the tensioner and idler. Car only has 54k on it. Now the code P0016 is gone. So for those who are receiving this you should think about having the timing belt looked at.
Reply With Quote
  #12  
Old 03-04-2007, 08:50 PM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: P0016 ??

Glad you got it figured out.
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
Old 03-04-2007, 08:50 PM
 
 
 
Reply

Tags
02, camshaft, check, code, engine, error, light, p0011, p0016, s40, s60, s80, timing, valve, variable, volvo, xc90


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 02:12 PM.
© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.
Secure Backup