Go Back   Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S60 & V60
Sign in using an external account
Register Forgot Password?
Search

Welcome to Volvo Forums!
Welcome to Volvo Forums,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Volvo Forums today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-06-2010, 07:30 AM
Junior Member
 
Join Date: Nov 2010
Posts: 4
Default S60 Dashboard Instruments/Lights Not Working

I have a 2003 S600 and the instrument panel goes dark and all the instruments stop working (speedometer, RPM, Fuel all go to zero) – This has occurs intermittently, the engine was running fine and no warning lights came on. I am also experiencing problems with indicator lights on the dashboard. As an example, the blinker lights on the dashboard only work about 20% of the time. The actual directionals on the exterior of the car are still working all of the time. The condition seems to be getting progressively worse.

I have 138, 000 miles on the car and appreciate any ideas on what the problem is and if it a DYI job or not.
Reply With Quote
  #2  
Old 11-07-2010, 09:05 AM
Senior Member
 
Join Date: Aug 2010
Location: Delaware
Posts: 234
Default

Quote:
Originally Posted by 2CMott View Post
I have a 2003 S600 and the instrument panel goes dark and all the instruments stop working (speedometer, RPM, Fuel all go to zero) – This has occurs intermittently, the engine was running fine and no warning lights came on. I am also experiencing problems with indicator lights on the dashboard. As an example, the blinker lights on the dashboard only work about 20% of the time. The actual directionals on the exterior of the car are still working all of the time. The condition seems to be getting progressively worse.

I have 138, 000 miles on the car and appreciate any ideas on what the problem is and if it a DYI job or not.
when this happens does your car run slugish......for example when your stopped and take of your car has all it can do to take off?? If so I may be able to help you after having experienced this myself it was a fuse that blew in position 32 it controlled the central electrical module which controls the entire instrument panel...but if yours is working I would say that your having an electrical problem...start with your fuses first and make sure all of them are fine and you have not blown any fuses at all....please post your findings. If we eliminate your fuses then we will have to look at your electrical system
Reply With Quote
  #3  
Old 11-07-2010, 10:04 AM
Senior Member
 
Join Date: Jul 2010
Posts: 299
Default

I had seem some of the 03 p2 problems w/DIM (instrument cluster). the problem is the DIM itself. usually symtom start w/srs light first. check if the sw of the DIM is updated or not, but most likely u need a DIM
Reply With Quote
  #4  
Old 11-08-2010, 10:20 AM
Junior Member
 
Join Date: Nov 2010
Posts: 4
Default

I will begin by checking the fuses and then post my findings.

I do have the SRS warning light that came on about a month ago.
Reply With Quote
  #5  
Old 11-08-2010, 10:46 AM
Senior Member
 
Join Date: Aug 2010
Location: Delaware
Posts: 234
Default

Quote:
Originally Posted by 2CMott View Post
I do have the SRS warning light that came on about a month ago.

When I blew the fuse that controlled the instrument panel my SRS Airbag light came on as well, your SRS light will need to reset by the dealer...you need a reset tool, I have yet to reset mine as the dealer want $100 to reset the warning light...good luck!
Reply With Quote
  #6  
Old 11-08-2010, 03:09 PM
Junior Member
 
Join Date: Nov 2010
Posts: 4
Default

Call my local mechanic -- he thinks it's the DIM. I will be bringing my car to him on Thursday so he can verify the problem. The DIM unit cost is approx $1,000.

Don't know if it is worth getting fixed or if I should just trade the car in. Overall a solid car with 138,000 miles and in good to excellent condition (for an 8 year old car).
Reply With Quote
  #7  
Old 11-08-2010, 10:24 PM
Senior Member
 
Join Date: Jul 2010
Posts: 299
Default

just a reminder, a local mechanic cannot really fix the dim. eg. OEM DTC's from vida, after dim replacement, u need to reload software on the dim.
Reply With Quote
  #8  
Old 04-04-2011, 01:58 PM
Junior Member
 
Join Date: Apr 2011
Location: London
Posts: 2
Smile Milf1977

hi everyone. I'm new to this forums but if I can I will try and help maybe someone with the dashboard problems with volvo s60 80 or v-series.I now from personal expierience beacuse my dashboard work for 5-10 min and then go blank.apparently is somethink wrong with the motorola chip.I read this from some forums.But the other day I plug my sat nav plus phone charger in cigaret lighter and from that time is working absolutly fine.here how I done it-- to the cigaret lighter in front(under radio) plug any charger(for sat nav or phone) and then to the other cigaret plug(locate it behind the armrest for driver,front of the rear seats ) plug second charger.leave them over night in sokets and when u start driving in the morning dont take them off at all. this is working 100% on my volvo s60. before I try this the dashboard works for 5-10 min and then blank screen.try !! maybe will work for u to!! good luck. please any one with similar dashboard problem let me now if this help u to resolve this issue.sorry for writing but I"m Polish and don't now perfectly english.
Reply With Quote
  #9  
Old 06-07-2011, 05:28 PM
Alb Alb is offline
Junior Member
 
Join Date: Jun 2011
Posts: 1
Default

I am new to this forum, and I am glad that it exist. Well it looks like that I'm not the only one with this type of problem. I own a S60 2003 and the instrumental panel stop working (speedometer,RPM,Fuel,Temperature all went to cero), the outside lights(directional)of the car are all working. The car does not run sluggish. All the fuses were check and are OK. The DIM(instrument cluster) was check and is not the problem. My mechanic thinks it's the Control Module TEMIC and that he can get a used one.
Reply With Quote
  #10  
Old 06-08-2011, 08:09 PM
Junior Member
 
Join Date: Nov 2010
Posts: 4
Default It was the DIM

Local mechanic was able to install new DIM and had to load software. DIM cost was about $900 (for a piece of plastic parts with a circut board ~ $10 worth of materials). Volvo really squeezes every cent out of you.
Reply With Quote
  #11  
Old 09-23-2011, 08:43 AM
Junior Member
 
Join Date: Sep 2011
Location: sedley saskatchewan
Posts: 5
Default 2003 XC 70 speedometer gages working intermitenly

I have purchased a used speedo and am told that a used one cannot be programed and need to spend 1000$ plus for a new one.The speedo and gages work fine it is the idiot lights and message center that go off and on. I was told cleaning the terminals on the back may work. Any ideas?
Reply With Quote
  #12  
Old 10-22-2011, 09:18 AM
Junior Member
 
Join Date: Oct 2011
Posts: 2
Default

2003 S60. While driving, the instrument lights went out and the gauges stopped functioning, but the bright light indicator and the climate control panel/radio panel still lit. The next morning, all looks good. This sounds similar to some of your experiences. Were any of you able to solve the trouble without spending $1000 on a new DIM?
Thanks for the help.
Mike
Reply With Quote
  #13  
Old 10-23-2011, 10:16 AM
Junior Member
 
Join Date: Sep 2011
Location: sedley saskatchewan
Posts: 5
Default

Sorry Boiler Mike , I have ordered a shop manuel for my XC 70 and plan on removing the Cluster and try cleaning the terminals if this works for me I will post on site.
Reply With Quote
  #14  
Old 10-30-2011, 08:49 PM
Junior Member
 
Join Date: Oct 2011
Posts: 3
Default

I had the same experience with my 2004 V70, including the loss of power. I thought I was having transmission problems. What is the connection between the instrument cluster and the power loss?
Reply With Quote
  #15  
Old 10-31-2011, 12:19 PM
Junior Member
 
Join Date: Oct 2011
Posts: 3
Exclamation Used DIMs

Be careful of this used part. I just spoke to my local Volvo specialist (not the dealer). He said if the used part is not re-manufactured correctly you will not be able to download the software because, basically, the part does not match the car. Volvo sells re-manufactured DIMs (for $1000!) that the software sees as "new". My guy will do the job for about $200 - $300 below the dealer. It's still going to be a $1300 job.
Reply With Quote
  #16  
Old 11-04-2011, 08:22 AM
Junior Member
2003 Volvo S60
 
Join Date: Nov 2011
Posts: 2
Default

The same thing was happening to my 2003 S60 two years ago. Shortly after this problem started I received a letter in the mail saying there was a recall on my model and Volvo would take care of it. They ended up having to replace the dash in my car and now it runs good. When the panel goes out does the car start to run badly?
Reply With Quote
  #17  
Old 11-05-2011, 08:53 AM
Junior Member
 
Join Date: Jun 2011
Location: Atlanta, GA
Posts: 16
Default

I'm having similiar problems. I have a 95 850 GLT. My instrument panel lights stopped working, and last night I was pulled over and got a ticked because my left headlight & right brake light were not working. I cringe to think how much this is going to set me back. Thank goodness I found an excellent mechanic here in Atlanta, still the cost has me freaking out.
Reply With Quote
  #18  
Old 11-05-2011, 09:34 AM
Junior Member
 
Join Date: Oct 2011
Posts: 3
Default

It only happened once so far but yes, the car ran very sluggish until I shut it off and restarted, then everything was fine. But now I have the SRS warning light. Lucky you got a recall.
Reply With Quote
  #19  
Old 07-22-2013, 01:33 PM
Junior Member
 
Join Date: Jul 2013
Location: Henrico, Va
Posts: 2
Default

I've found that resoldering (or just applying hot air) the pins on the motorola chip [after cleaning it up] will get the cluster working again. Acetone and a brush will work well with getting the blue "gunk" off of the chip. Any other ideas that come to mind?
Reply With Quote
  #20  
Old 07-22-2013, 02:18 PM
Senior Member
 
Join Date: Jun 2013
Posts: 130
Default

Mizundastud, all dashes from 2002-2003 model year of S60/S80/V70/XC70/XC90
have this issue and can be rebuilt. If the dash is not completely dead rebuilding helps in 100% of cases. Sometimes the firmware gets corrupted.
Reply With Quote
Old 07-22-2013, 02:18 PM
 
 
 
Reply

Tags
blown, cluster, dark, dash, dashboard, forum, headlights, instrument, jump, motor, panel, running, s60, start, v70, volvo, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 09:19 PM.
© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.
Secure Backup