Go Back   Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S70
Sign in using an external account
Register Forgot Password?
Search

Welcome to Volvo Forums!
Welcome to Volvo Forums,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Volvo Forums today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-28-2012, 03:29 PM
Member
 
Join Date: Feb 2012
Posts: 42
Default Flashing Arrow and Check Engine Light

I was cruising home on the expressway today and out of nowhere my dashboard lights up with a flashing arrow and the check engine light goes on.

I didn't hit anything or feel anything. The car needs an oil change in about 500 miles. That's it. I look in the owner's manual and it says there is a problem with the gear box.

All the shops in my area are closed today so I can only do so much. From my own research it seems it's the PNP switch failing. I was already in 3rd though and even later once I got off the expressway the car accelerated fine. Didn't feel like I was in 3rd the whole time or anything. I shifted between park and L vigorously a few times and it didn't seem to do anything.

Is the check engine light on as a result of this or is that something else entirely?

How far/long can I drive it like this? I have a doctor's appt tomorrow morning that I can't miss.

Automatic 99 S70 GLT with 160K on it (6K are me)
Reply With Quote
  #2  
Old 05-28-2012, 03:39 PM
Member
 
Join Date: Feb 2012
Posts: 42
Default

The car is also FWD...
Reply With Quote
  #3  
Old 05-28-2012, 04:22 PM
rspi's Avatar
Administrator
1995 Volvo 850
My Garage
 
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,655
Send a message via Yahoo to rspi
Default

Why were you in 3rd?

You should be able to drive a long way like that. Just not good on the tranny if you ignore it to lone. If it's the PNP switch, it should not bother the tranny. If rolling the shifter cleared it up a little you won't have the flashing arrow unless the problem repeats itself, just the cel. Of the ARROW comes back on it will not use 1st or 2nd, just 3rd and 4th.

How long have you had the car? Have you ever had the tranny serviced?
__________________
'95 850 T-5R Wagon - Panther - Daily Driver 22 / 28 mpg
'98 S70 GLT - Lil' Red - Daughter 22/30 mpg
--------------------------------------------
Volvo Repair Videos - Used Parts For Sale - Interior Lights For Sale - ABS Light? Click Here - Men's Mentoring
--------------------------------------------
Volvo's of time past: '87 740 GLE, '79 262C Bertone, '78 264, '95 960, '97 960, '98 S90, '98 S70 GLT, '95 850 T-5R Yellow, '95 960, ,96 850 R...

Last edited by rspi; 05-28-2012 at 04:23 PM. Reason: add
Reply With Quote
  #4  
Old 05-28-2012, 04:40 PM
Member
 
Join Date: Feb 2012
Posts: 42
Default

I was driving with the car in Drive, on the expressway, and it was in 3rd when the light came on. Sorry for the confusion.

I've had it for about 4 months and have not had the tranny serviced.
Reply With Quote
  #5  
Old 05-28-2012, 05:22 PM
Member
 
Join Date: Feb 2012
Posts: 42
Default

How do I get that whole center console area open. I really want to clean it now that I'm playing around with it.
Reply With Quote
  #6  
Old 05-28-2012, 09:51 PM
rspi's Avatar
Administrator
1995 Volvo 850
My Garage
 
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,655
Send a message via Yahoo to rspi
Default

Google it. You will likely find instructions on Matt's site or VolvoSpeed. On the 850's you have a couple of screws behind the rear ash tray assembly (which pulls out), 2 screws in the arm rest area, a couple of screws near the front side of the coil holder and a couple behind the ash try and the entire thing pulls out. Not 100% sure about the S70's.
__________________
'95 850 T-5R Wagon - Panther - Daily Driver 22 / 28 mpg
'98 S70 GLT - Lil' Red - Daughter 22/30 mpg
--------------------------------------------
Volvo Repair Videos - Used Parts For Sale - Interior Lights For Sale - ABS Light? Click Here - Men's Mentoring
--------------------------------------------
Volvo's of time past: '87 740 GLE, '79 262C Bertone, '78 264, '95 960, '97 960, '98 S90, '98 S70 GLT, '95 850 T-5R Yellow, '95 960, ,96 850 R...
Reply With Quote
  #7  
Old 05-29-2012, 10:29 AM
Senior Member
 
Join Date: Dec 2006
Location: Denver, CO
Posts: 323
DaveLeachDenver
Send a message via AIM to TacklaNHL
Default

Strange. I had this exact same problem on my '95 850 Wagon (250,000 miles on it) yesterday.

I was on the on-ramp to get onto the interstate... the flashing arrow comes on and the CEL lights up. Yet, the car felt and drove fine.

I did notice when I got to a stop-light at my off-ramp that my low gears were unavailable to me. It drove, just felt like it had no power when I accelerated.

I have the transmission flushed every 3 years, and just had it done last fall.

When I got home I shut the car down and checked the trans-fluid level... which was fine... turned it on again and the gears were back!!! The arrow was still flashing, and the CEL was on though. But the car is running like normal right now.

I had it scanned this morning at the parts store... I don't know if the guy just didn't use it right or what, but he said there was no code?!?! I had him clear it anyway so that I can see if it comes back. Like I said, the car is running fine right now... so we'll see what happens. And currently, there is no flashing arrow or CEL (probably because he cleared it.)

I replaced the PNP switch myself, maybe 4 years ago (I'd have to look it up)... anything else you guys think it could be?

Thanks for the help.
__________________
2007 S60R, Magic Blue Pearl
Reply With Quote
  #8  
Old 05-29-2012, 11:43 AM
Member
 
Join Date: Feb 2012
Posts: 42
Default

Got it scanned today. PNP switch is fine.

I didn't lose any of my gears. And I could even engage W mode. The arrow was still flashing but it was working fine.

Got it scanned today and here are the faults.


CCM-414- Fan motor passenger compartments temperature sensor faulty signal- FaultUnknown
ECM-530D- MIL TCM- FaultCurrent
ECM-91A7- Throttle Position- Faulty Control- FaultCurrent
TCM-002F- Lock-up Function Slipping or not engaged- FaultCurrent
CDM-0001 VSS missing- FaultPrevious

This is probably worse than it being the PNP Switch. Got them cleared and nothing popped up on the way back home. Going to keep an eye on it though.

Did the guy at your local parts store have a Volvo scanner?
Reply With Quote
  #9  
Old 05-31-2012, 12:31 AM
Member
 
Join Date: Feb 2012
Posts: 42
Default

Now my car starts, but if I try to put it into gear it just dies. I can leave it in N or P, but anything else and it dies.

Guessing I've got a case of lock-up, but not sure how to fix it or how it happened. Towed to my Volvo mechanic and awaiting his diagnosis. Hopefully it is a failed solenoid somewhere and not the trans because that would essentially be a death sentence.
Reply With Quote
  #10  
Old 06-04-2012, 02:30 PM
Member
 
Join Date: Feb 2012
Posts: 42
Default

Torque converter is completely shot. I had no idea how hard it is to find a used transmission for a GLT. Found one with 104,000 miles on it for 900.
Reply With Quote
Old 06-04-2012, 02:30 PM
 
 
 
Reply

Tags
2000, arrow, blinking, check, clearing, dashboard, engine, flashing, light, mil, s70, sign, transmission, vilvo, volvo, volvoengine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 03:35 AM.
© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.
Secure Backup