Go Back  Volvo Forums - Volvo Enthusiasts Forum > General Volvo Forums > General Volvo Chat
Reload this Page >

2003 S40 1.9 All symptoms point to temp control sensor. but not.

General Volvo Chat Post Your Questions And Comments on any of Volvo's many models.

2003 S40 1.9 All symptoms point to temp control sensor. but not.

  #1  
Old 07-23-2018, 01:32 PM
Junior Member
Thread Starter
Join Date: Jul 2018
Posts: 9
Default 2003 S40 1.9 All symptoms point to temp control sensor. but not.

Hi. wondering if anyone can help. 1- cooling fan works but does not turn on when hot. 2- cooling fan sometimes turns on when cold just when key is on and then for a little while. 3- engine surges. 4- will not restart or very hard to start after engine running for a while. Temperature gauge erratic. jumps to hot for a second or two when cold then registers cold when engine is hot.

Cooling system is full. Thermostat is opening. Changed the temp control sensor. Fans work when A/C turned on. No check engine light coming on and no codes.checked plug connectors.
I dont where to go next...Anybody???
 
  #2  
Old 07-23-2018, 07:08 PM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,675
Default

I saw a similar post in the S40 section - I can merge or delete this one. you may also find some insights at volvowiringdiagrams.com
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pawright
General Volvo Chat
0
07-19-2014 10:11 PM
platinum_ghost
Volvo 240, 740 & 940
25
11-07-2012 12:41 PM
chef
Volvo 850
16
08-22-2008 07:57 AM
vcolper
Volvo 240, 740 & 940
1
11-01-2006 10:20 PM


Thread Tools
Search this Thread
Quick Reply: 2003 S40 1.9 All symptoms point to temp control sensor. but not.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.