Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo 240, 740 & 940
Reload this Page >

940 no start need help got fire to the plugs got fuel got weak injector pulse checked

940 no start need help got fire to the plugs got fuel got weak injector pulse checked

  #1  
Old 06-26-2019, 08:03 AM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 4
Default 940 no start need help got fire to the plugs got fuel got weak injector pulse checked

Got spark fuel weak noid on injectors timing belt good compression 150psi 165psi 160psi 165psi so what could it be put new engine speed sensor new fuel pump in tank and fuel pump relay
 

Last edited by Ken Johnson; 06-26-2019 at 08:17 AM. Reason: 93 volvo 940 turbo
  #2  
Old 06-26-2019, 02:35 PM
Former Moderator
Join Date: Oct 2010
Location: 37 North on the left coast
Posts: 9,995
Default

is this a turbo? and what year? there's some variations on how the injectors are powered, but generally, the juice comes from the 'radio suppression relay' on the left fender, which is turned on with ignition, and if its a turbo, there's series 'load resistors' before the injectors... the ECU 'grounds' the injectors to fire them, one output, all 4 injectors fire at the same time, twice per ignition cycle.
 
  #3  
Old 06-26-2019, 09:44 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 4
Default 1993 940 turbocharged

1993 940 turbocharged
 
  #4  
Old 06-26-2019, 10:07 PM
Former Moderator
Join Date: Oct 2010
Location: 37 North on the left coast
Posts: 9,995
Default

so, battery -> RSR -> load resistors -> injectors hot side.
injectors other side -> ECU
 
  #5  
Old 06-27-2019, 06:24 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 4
Default Pierce

[QUOTE=pierce;474897]so, battery -> RSR -> load resistors -> injectors hot side.
injectors other side -

> ECU[/QUOTE

I got 10 to 11 volts at the injectors batterys at 12.2 volts
 
  #6  
Old 07-06-2019, 01:15 PM
Former Moderator
Join Date: Oct 2010
Location: 37 North on the left coast
Posts: 9,995
Default

12.2 volts is way too low. a fully charged lead acid battery at rest with no load should be about 12.6V ... 12.2 is nearly 50% discharged.
 
  #7  
Old 07-11-2019, 03:53 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 4
Default Pierce

Pierce help me out with this volvo its pissing me off i put a cap and rotor on it still no start; rotor Ω 1152 Ω checked all grounds battery at 12.8 volts got the exhaust discounted not a flow problem
 

Last edited by Ken Johnson; 07-11-2019 at 03:57 PM.
  #8  
Old 07-11-2019, 04:00 PM
Former Moderator
Join Date: Oct 2010
Location: 37 North on the left coast
Posts: 9,995
Default

insufficient information to even begin to guess whats wrong.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cabinover
Volvo 240, 740 & 940
0
06-23-2019 04:19 PM
mtps
Volvo 850
11
01-25-2019 01:25 AM
Team423
Volvo S40
0
07-17-2015 09:50 AM
mr.Bean240
Volvo 240, 740 & 940
6
04-13-2012 03:22 PM
gl1970
Volvo 240, 740 & 940
3
08-28-2007 02:40 PM


Thread Tools
Search this Thread
Quick Reply: 940 no start need help got fire to the plugs got fuel got weak injector pulse checked


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.