Problems with 1989 765 with B280F PRV Engine - Volvo Forums - Volvo Enthusiasts Forum

Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo 260, 760 & 960
Reload this Page >

Problems with 1989 765 with B280F PRV Engine

Problems with 1989 765 with B280F PRV Engine

Reply

 
 
 
  #1  
Old 05-29-2018, 12:07 PM
Junior Member
Thread Starter
Join Date: Mar 2013
Location: austria
Posts: 9
Default Problems with 1989 765 with B280F PRV Engine

Hi Everyone, Greetings from Europe, i need Help!


I am currently in the process of registering an imported 1989 765 from Germany in Austria.
It has the B280F PRV Engine, but failed the Emissions Test today. Both Lambda and HC Values are too high.



from Memory:
HC at Idle 680, should be 66
Lambda at Idle 1,043, should be 1,003


At higher RPM the Values were off as well, but not that bad.


.)Airfilter is new
.)Sparkplugs and Cables are new
.)Distributor Cap and Finger are new
.)Catalyst und Lambdasond are old
.)LH2.2 Version with no Diagnostics, not even the blinking LEDs the B230F's have
.)40l fresh Petrol, roughly 20l 1-1,5 year old Petrol from the previous owner in the Tank
.)system cleaner in the tank


what else could i do ??


this version LH can not blink fault codes, so that's not an option.


Can i try an Air Mass Meter from a same Year B230F or are they different?


My Catalyst looks exactly like a B230F one, and the whole exhaust is not leaking, but a botch job, Should a B280 Cat be bigger than a B230 one? could i have a B230 Catalyst on there? ...and if so, could that cause bad emission Values ??




what to do ??
help !!!


...and thanks in advance !
 
Reply With Quote
  #2  
Old 05-29-2018, 03:23 PM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 3,830
Default

air leaks can cause this - check both intake tubing as well as exhaust. You may also need to replace the O2 sensor (probably an old one wire model...).
 
Reply With Quote
  #3  
Old 07-11-2018, 10:39 AM
Junior Member
Thread Starter
Join Date: Mar 2013
Location: austria
Posts: 9
Default

thanks, its all good now.

replaced the ignition stuff from finger to plug,
and all the seals on the intake side,
and now it is all good.

 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
edolson
Volvo 260, 760 & 960
0
07-11-2012 04:52 PM
edolson
All Other Volvo's
0
07-11-2012 02:24 PM
wmjodea3
Volvo 260, 760 & 960
3
08-09-2009 08:40 PM
JP
Volvo 260, 760 & 960
8
07-09-2009 03:17 PM
jaapfijn
Volvo 260, 760 & 960
3
08-11-2005 10:51 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory