Volvo S70 Made from 1998 to 2000, this sporty model replaced the 850 sedan and instantly became a hit.

99 S70 cuts off and hard to start.

  #1  
Old 04-27-2010, 02:53 PM
Member
Thread Starter
Join Date: Apr 2010
Posts: 37
Default 99 S70 cuts off and hard to start.

Hello,

I am hoping someone can help me with this problem - My 1999 S70 non-turbo with 105K miles cuts off when coming to a stop, usually after it warms up. When this happens it can be hard to start. It will crank and you have to give it the right amount of gas for it to start again. Sometimes you have to hold the gas pedal all the way down and it will finnally start. You can keep the car running at a stop if you put it in neutral and press the gas to keep the RPMs up. I looked for a loose or broken vacuum line, could not find one. Checked wiring connections. It also has ODBII code P1057 stored, not sure what this code even means, scan tool did not say. You can hear the fuel pump keeps running and it has fuel pressure at the fuel rail even when it dies.

I would prefer to not just throw parts/money at it randomly. Please, any sugestions you could provide will be greatly apreciated.
 
  #2  
Old 04-27-2010, 09:50 PM
Join Date: Apr 2007
Posts: 83
Default

We had the exact same problem 4 years ago, I am not sure what it was, but it was some kind of idling sensor that cost us around $600 to get it fixed at the dealer. It will keep on getting on getting worse and worse until you get it fixed. We waited 3 weeks, it used to happen probably once or twice a day, but at the end it started to happen on every traffic light. Might be something else but I think you should have it checked out A.S.A.P. for that code.
 

Last edited by 2004VolvoS60_Bilal; 04-27-2010 at 10:01 PM.
  #3  
Old 04-30-2010, 09:34 PM
Member
Thread Starter
Join Date: Apr 2010
Posts: 37
Default

Thank you for the reply. I had to take apart the air cleaner pipes just to fine the Idle control valve. On a 99 S70 the ICV is located in the back of the air intake black rubber tubes/pipes, different spot then a 98, and different ICV. I did locate a couple of vacuum lines that were not connected. I ran new ones. I took apart the ICV and cleaned it. What else I discovered was what appears to be oil in the throttle body. It actually was coming from the tube that connects to the large throttle intake pipe. All in there right before the throttle body was all gunk up with oil. Does anyone know what could be causing this?
 
  #4  
Old 05-05-2010, 07:13 PM
xmax92xd's Avatar
Junior Member
Join Date: May 2010
Posts: 1
Default

I actually had a problem similar to what you are describing just a few weeks ago with my 1998 S70. It turned out to be a sensor that regulates the gas to air mixture. I had trouble starting the car but I could get it to idle after a couple tries, and whenever I stepped on the gas the engine would cut out. It's a simple fix, probably around $200 for the new part. Hope this helps.
 
  #5  
Old 07-15-2010, 11:57 PM
Member
Join Date: Jul 2010
Location: Denver CO
Posts: 78
Default

I had a MAF code P0107 that caused random cut outs on the highway or city streets but if I was idling it would die and then be a pain to start from 30 seconds to 5 minutes. I changed the MAF and it has stumbled twice but not died when idling. When the day is cool it is not bad and when we are at 99 it was okay for maybe the first 40 minutes and then it got worse. So parking for a while made it get better.

Solve all the code problems that relate air flow through the engine. The IAC is a simple valve and it sends a signal to change position and reads the current used to move it to determine if the valve changed position. So the test for proper operation is pretty weak. At least on my 98.
 
  #6  
Old 07-19-2010, 05:15 PM
Member
Thread Starter
Join Date: Apr 2010
Posts: 37
Default

I think the biggest cause of this issue had been a clogged PCV system. I disconnected the hose that connects near the throttle body intake and ran it to a plastic bottle to catch the oil. With it like this I am able to drive it arround with out it cutting off. I am in the process of changing out the PCV system and will clean out the intake.
 
  #7  
Old 09-23-2010, 08:13 PM
Member
Thread Starter
Join Date: Apr 2010
Posts: 37
Default

I have changed out the pcv system on this car. The intake manifold was full of gunk and oil. I soaked it and cleaned it out. I cleaned the intake part of the head as best as I could. The valves get dirty from this condition. Advise to use intake/fuel cleaner, when finished. When I finished and put it all together, the car ran fine. Always starts, & stopped dying out. Car runs with good power now. Just wanted to update the thread - hope this helps others.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
KaMiKaZi_t0M
Volvo S70
1
03-10-2013 01:10 AM
sdehaven4
Volvo S70
1
05-25-2010 08:23 PM
maitresaman
Volvo 240, 740 & 940
1
05-01-2007 02:02 PM
Italiano86
Volvo 240, 740 & 940
5
02-03-2007 10:25 PM
maitresaman
Volvo 240, 740 & 940
9
04-07-2006 07:39 PM


Thread Tools
Search this Thread
Quick Reply: 99 S70 cuts off and hard to start.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.