Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2000 S80 ABS/STC

  #1  
Old 02-28-2008, 07:10 PM
Thread Starter
Join Date: Feb 2008
Location:
Posts: 3
Default 2000 S80 ABS/STC

I had been experiencing the common problem of the ABS/STC lights coming on on my 2000 S80 T6. I sent the ABS / STC controller out for rebuild, and upon reinstalling, the lights did not go out, but the check engine light came on when restarting a second time. I pulled a code of 1550 on my generic code reader. I can erase the code, but it reappears on restart. I think this code indicates no signal from a wheel speed sensor. How do I know which wheel sensor? Can I test these, without the Volvo VADIS? Are they the newer type of ABS speed sensors that you cannot check by just checking resistance? I've heard these newer ones are actually powered active components.

Could it have been a bad rebuild? I used BBA Reman, and I actually called them afterward, with my problem. They said that the code is now registering since the controller is now working, vs. before, it was not.

Thanks!
 
  #2  
Old 02-28-2008, 07:20 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: 2000 S80 ABS/STC

Have the ABS codes cleared.
 
  #3  
Old 02-28-2008, 10:07 PM
Senior Member
Join Date: Dec 2006
Location:
Posts: 311
Default RE: 2000 S80 ABS/STC

Double check your connections on the ABS controller...
 
  #4  
Old 02-29-2008, 02:12 PM
Senior Member
Join Date: Mar 2007
Location:
Posts: 200
Default RE: 2000 S80 ABS/STC

When I reinstalled mine several months ago I did not pull the little slide lock bars out therefore I did not get the hook up good Make sure that did not happen to you They are located on the side and you need to put them back inafter you hook up On My 2001 S80 I did not have to clear the codes they cleared themself after about 5 min of driving
 
  #5  
Old 02-29-2008, 09:06 PM
Senior Member
Join Date: Dec 2006
Location:
Posts: 311
Default RE: 2000 S80 ABS/STC

Any update?
 
  #6  
Old 03-03-2008, 05:08 PM
Thread Starter
Join Date: Feb 2008
Location:
Posts: 3
Default RE: 2000 S80 ABS/STC

Thanks everyone. I'm going to check my connections tonight. I've already checked once, but I will again, as this seems to be the most logical problem. I opened the latch/hood on the connector, put the connector in the socket on the controller, and pushed down the hood, and it appreared to correctly "pull" down the plug into the socket.
Otherwise, I think I've got a bad wheel speed sensor.
 
  #7  
Old 03-07-2008, 06:05 PM
Thread Starter
Join Date: Feb 2008
Location:
Posts: 3
Default RE: 2000 S80 ABS/STC

I checked the plug, and it is fully seated. I also checked the wiring to each sensor plug, on the firewall (front sensors) and under the rear seat (rear sensors). All OK. Now, I just need to check each sensor itself, but how? I did read about measuring the voltage output as you turn the wheel, and I will try that this weekend.

thanks!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JCVolvoS80
Volvo S80
8
05-01-2017 01:48 PM
2000volvos70glt
Forum Issues
0
10-04-2014 07:32 PM
SilverS80
General Volvo Chat
1
08-26-2008 06:36 PM
njvvgirl
Volvo S80
6
04-13-2008 07:29 PM
JPizano23
Volvo S80
1
05-12-2005 10:04 PM


Thread Tools
Search this Thread
Quick Reply: 2000 S80 ABS/STC


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.