Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Emissions System Service Required...

  #1  
Old 04-13-2005, 03:43 PM
Thread Starter
Join Date: Mar 2005
Location:
Posts: 21
Default Emissions System Service Required...

I just got this message on my computer along with a constant "Check Engine" light. Has anyone had this one before? If so, what's the fix? I just had a 75K service, shouldn't this have been covered? Thanks, Gonzo
 
  #2  
Old 04-13-2005, 05:35 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emissions System Service Required...

It could be about 100 different things.You need top have the codes pulled and see what they are.
 
  #3  
Old 04-13-2005, 11:50 PM
Join Date: Mar 2005
Posts: 97
Default RE: Emissions System Service Required...

When I had that error, It was because my O2 sensor was malfunctioning, and I had to get a new one (didn't have to pay for it). It also might be an intermittent problem, meaning it will go on and off (which is what happened to me). If you need to get a state inspection, wait until the light goes off. A "check engine" light is an automatic failure, and S80's have a problem passing emissions anyway. If you have the Emission system message, the emissions test will probably fail.
 
  #4  
Old 04-14-2005, 12:17 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emissions System Service Required...

It could also be a dirty/bad throttle module.
It could also be a loose gas cap.
It could also be a vaccum leak.
It could also be a bad gas pedal sensor.
It could also be a bad evap. valve.
It could also be a bad fuel tank pressure sensor.

ETC
 
  #5  
Old 04-15-2005, 08:50 AM
Thread Starter
Join Date: Mar 2005
Location:
Posts: 21
Default RE: Emissions System Service Required...

Thanks for all the possible solutions, but I'm taking it in to the shop this morning. I will keep you posted
 
  #6  
Old 05-19-2005, 02:52 PM
Join Date: May 2005
Posts: 7
Default RE: Emissions System Service Required...

My cars light also came on a few days back and I have been advised that the O2 sensor has to be replaced. I was shocked at the price and was wondering if the system can be bypassed, or disconnected. I have only had the car a two weeks and bought it second hand, I hope I haven’t bought a dud !! Do these cars give a lot of trouble ?
 
  #7  
Old 05-19-2005, 07:49 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emissions System Service Required...

O2 sensors are somewhat of a problem on these cars.
Most of the S80's are good.There are some that have problems.

No the system can't be bypassed or the car won't run properly at all.
That is one of the most important sensors of the emmissions system.
The sensor adjusts the fuel system and keeps the emmissions levels down.
 
  #8  
Old 05-20-2005, 10:12 AM
Join Date: Feb 2005
Posts: 10
Default RE: Emissions System Service Required...

I had this error for about 2 weeks and it went away. I am almost 100% sure it was the gas cap, but it came back like 1 month later 45 minutes after filling up the tank. Like i said, i think its the gas cap, but when i was trying to determine what caused it I also tried this http://apps.volvocars.us/ownersdocs/...Inspection.pdf

I really do not think this had anything to do with it, but it is either my gas cap or the instructions in that link.

Tech would probably know the answer to that.
 
  #9  
Old 05-20-2005, 10:45 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emissions System Service Required...


ORIGINAL: toetag

I had this error for about 2 weeks and it went away. I am almost 100% sure it was the gas cap, but it came back like 1 month later 45 minutes after filling up the tank. Like i said, i think its the gas cap, but when i was trying to determine what caused it I also tried this http://apps.volvocars.us/ownersdocs/...Inspection.pdf

I really do not think this had anything to do with it, but it is either my gas cap or the instructions in that link.

Tech would probably know the answer to that.
Remove the gas cap and look in by the threads and make sure the rubber seal is seated all the way.
 
  #10  
Old 05-20-2005, 01:21 PM
Thread Starter
Join Date: Mar 2005
Location:
Posts: 21
Default RE: Emissions System Service Required...

Sorry about the delay. JC was right, it was the O2 sensors. I also had the motor mounts replaced and head light bulbs. Needless to say I dropped a bundle. Oh well, did I mention the car runs like champ now?

Gonzo
 
  #11  
Old 05-20-2005, 01:59 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emissions System Service Required...

I bet it drives like a new car!!
 
  #12  
Old 05-20-2005, 08:44 PM
Thread Starter
Join Date: Mar 2005
Location:
Posts: 21
Default RE: Emissions System Service Required...

You bet it does! The ride made me forget the grand I spent.

Gonzo
 
  #13  
Old 05-21-2005, 11:30 AM
Join Date: May 2005
Posts: 7
Default RE: Emissions System Service Required...

Thanks Tech for the information and super fast response
 
  #14  
Old 05-21-2005, 05:13 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Emissions System Service Required...

No problem Glad I could help.
 
  #15  
Old 07-11-2005, 01:11 PM
Join Date: May 2005
Posts: 27
Default RE: Emissions System Service Required...

I just got the "Emmission System Service Required" message with the Check Engine light. I checked the gas cap and it differently wasn't on correctly, so I closed it correctly. I just started the car in the parking lot for a couple of minutes and the message did not reset. Can I reset it?

2000 S80 T6, 108K mi
 
  #16  
Old 07-13-2005, 01:25 PM
Member
Join Date: Jun 2005
Posts: 34
Default RE: Emissions System Service Required...

Just resolved a similar problem last month. It was my O2 sensor. Cost about $830.00 to repair.
 
  #17  
Old 07-14-2005, 09:48 PM
Join Date: May 2005
Posts: 27
Default RE: Emissions System Service Required...

Luckily it was the gas cap but it took a couple of days for the message to clear. I was sweaty it because I had just spent $900 on the oil pan "o" rings
 
  #18  
Old 07-18-2005, 02:06 AM
Join Date: Jul 2005
Location: Los Angeles, CA
Posts: 343
Default RE: Emissions System Service Required...

I own a 1999 S80 T6 and also have the Emissions Service Required and Check Engine errors. However, I took my car to the shop and they told me there might be a small, unnoticeable hole or opening in one of the valves that is inside the engine. I've been using the car for 5 months since with no problems and decided not to spend the money to fix this 'unnecessary' problem. However, it did originally turn off periodically or would tell me that my Fuel Filler Cap is open which may indicate that the problem has to do with the Oxygen sensor.
 
  #19  
Old 12-09-2005, 12:00 AM
Junior Member
Join Date: Sep 2005
Posts: 12
Default RE: Emissions System Service Required...

I have a 99 S80 non turbo and the codes that were p1171 and p1181. Can any one tell me whats wrong.
Also are there one or two oxygen sensors.
 
  #20  
Old 12-09-2005, 03:23 AM
Senior Member
Join Date: Nov 2005
Location: Burlington, ma
Posts: 1,129
Default RE: Emissions System Service Required...

When my emmissions message came up, it came on because my MASS flow air sensor was not working correctly, whats that sensor do(control the air intake), i have a s80 t6!.....
 

Thread Tools
Search this Thread
Quick Reply: Emissions System Service Required...


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.