Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

No heat or fan 08 S80

  #1  
Old 03-22-2014, 05:57 PM
Junior Member
Thread Starter
Join Date: May 2009
Posts: 18
Default No heat or fan 08 S80 - UPDATE

Ok, I replaced the water pump, belt tensioner and idler puller for a friend on his 08 S80 3.2 but now the fan doesn't want to run(blower motor) and it doesn't really get any warm air when it does blow. Any ideas? I'm pretty sure I only unplugged the mass air sensor while doing this.
Is there a good way to bleed the cooling system? I did the same way I do on pretty much every other car I've worked on but maybe there is a trick to this one.


Thanks!


Ok so I rechecked what I did and it all looks good. It did have a "Thermostat under temp" code, or something like that. The hoses all get warm and seem to have pressure in them. The fan however does in deed come on but does NOT run all the time, even when the climate control is turned OFF.
While I was changing the oil I squeezed one of the hoses and heard a whistling kind of noise up top. If this is a sign of air in the cooling system how the heck do I get it out? it's not a high spot where I would expect air to "settle".


Thanks.
 

Last edited by parrothead71; 03-23-2014 at 02:33 PM. Reason: Some new information
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
KMD
Volvo 240, 740 & 940
7
01-21-2015 06:38 AM
waynepearson
Volvo S40
1
01-21-2013 08:21 PM
wondering
Volvo V70
1
07-16-2011 08:01 AM
NoWayJose
Volvo S60 & V60
1
04-26-2007 03:05 AM
oldbug
Volvo 850
1
12-17-2004 10:46 AM


Thread Tools
Search this Thread
Quick Reply: No heat or fan 08 S80


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.