Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Odometer Problems....

  #1  
Old 03-14-2009, 04:08 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default Odometer Problems....

99 S80 - The odometer has not changed since I bought the car two weeks ago. Is there a wire or cable on the transmission that may have come disconnected?

It was working recently, there's an oil change sticker on the car from a couple of months ago at 108,000...now I'm stuck at 109,524.
 
  #2  
Old 03-14-2009, 04:54 AM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:58 AM.
  #3  
Old 03-14-2009, 05:12 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

No, the ABS light isn't on. Is the odometer computer controlled?
 
  #4  
Old 03-14-2009, 05:29 AM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:58 AM.
  #5  
Old 03-14-2009, 05:49 AM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:58 AM.
  #6  
Old 03-14-2009, 07:59 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

So, my STC light is also on, the cruise and text window in the lower right hand side of the cluster don't work...possibly all related?

Would my car be OBDII?
 
  #7  
Old 03-14-2009, 08:08 AM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:58 AM.
  #8  
Old 03-14-2009, 08:13 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

It's actually a US car, I've found myself doing 100 miles per hour before remembering the speedo isn't in kmph.

Is does have a port above the foot pedals. Now to find a code reader....
 
  #9  
Old 03-14-2009, 08:16 AM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:59 AM.
  #10  
Old 03-14-2009, 09:24 AM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:59 AM.
  #11  
Old 03-14-2009, 10:59 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

I can't get it to turn on. The light on the button is always on, as though it's in override mode.
 
  #12  
Old 03-14-2009, 12:30 PM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:59 AM.
  #13  
Old 03-14-2009, 03:14 PM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

Ok...I must have misread the owners manual, in my VW the light comes on when it's on override. But this leads to another question, the owners manual say to hold the button down for a couple of seconds to override STC - which I've done with no results.

I think the bast thing I can do is take it to a volvo shop and have them plug it in to see what comes up.
 
  #14  
Old 03-14-2009, 03:36 PM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:59 AM.
  #15  
Old 03-15-2009, 06:57 PM
Senior Member
Join Date: Dec 2008
Location: Rosemount, MN
Posts: 353
Default

Did you call the dealer? It's illegal for them to sell a vehicle without a functioning odometer. I'd call them first and make them cover getting it fixed. After all, it's the law, and they would much rather have it fixed for you than you file a complaint.
 
  #16  
Old 03-16-2009, 05:05 PM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

Originally Posted by JTapper View Post
Did you call the dealer? It's illegal for them to sell a vehicle without a functioning odometer. I'd call them first and make them cover getting it fixed. After all, it's the law, and they would much rather have it fixed for you than you file a complaint.
I bought it at an auction....
 
  #17  
Old 03-16-2009, 05:08 PM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

I borrowed a code reader from a friend, there were a few codes for misfires and unstable idle which I had already fixed. I cleared the codes and the only one that came back is P1633 - KVM Voltage Too Low.

I've already wondered about the battery and have had in on the trickle charger for a few hours and it won't charge more than 4 amps. Could my problems be related to the computer not receiving enough voltage from the battery?
 
  #18  
Old 03-16-2009, 05:42 PM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:59 AM.
  #19  
Old 03-16-2009, 05:54 PM
Banned
Join Date: Sep 2008
Location: Knoxville, TN
Posts: 213
Default

12345
 

Last edited by Crito; 03-24-2009 at 07:59 AM.
  #20  
Old 03-17-2009, 06:48 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Location: Hubbards, Nova Scotia
Posts: 13
Default

I checked the fuses as you suggested on the weekend (2 30 amps under the hood), they looked fine. Are the ABS sensors located in the wheel hubs? Could it be that one is bad or has become disconnected?
 

Thread Tools
Search this Thread
Quick Reply: Odometer Problems....


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.