Go Back   Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo 240, 740 & 940
Sign in using an external account
Register Forgot Password?
Search

Welcome to Volvo Forums!
Welcome to Volvo Forums,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Volvo Forums today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-04-2008, 08:20 AM
Junior Member
 
Join Date: Sep 2008
Posts: 6
Default ALTERNATOR 940

GREETINGS TO ALL FROM MOCA,PUERTO RICO. I RECENTLY PURCHASEDA 1995 940 N/TURBO AND HAVE A QUESTION CONCERNING

THE ALTERNATOR. THE DARNTHING WOULD NOT CHARGE IF THE LIGHTS AND OR THE A/C WERE TURNED ON.SINCETHE ITEM HAS

A LIFETIME GUARANTEEI GOT A REMANUFACTURED ONE BUT THE SAME THING OCCURS. IS THERE ANYTHING THE MECHANIC IS

MISSING OR IS IT THAT THE NEW ONE IS ALSO A BUMMER ? ANY SUGGESTIONS?


THANKS A BUNCH LESLIE
Reply With Quote
  #2  
Old 10-04-2008, 04:31 PM
Junior Member
 
Join Date: Oct 2008
Posts: 22
Default RE: ALTERNATOR 940

[align=left]How do you know it's not charging? Does the battery go dead?

A lot of times, when I have a problem like this, I'll go ahead and replace the battery at the same time as the alternator. How old is your battery? Do you know? If not, then just as a good measure, I would replace the battery too. Then you know your whole charging system is new.
[/align][align=right] [/align]
Reply With Quote
  #3  
Old 10-04-2008, 04:36 PM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: ALTERNATOR 940

Check the Alt. gounding.
If the ground wire is messed up it will cause the same problem.
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
  #4  
Old 10-05-2008, 08:08 AM
Junior Member
 
Join Date: Sep 2008
Posts: 6
Default RE: ALTERNATOR 940

jsinton& tech: okay on the battery. it's new(i believe 580 amps cold is the term). I'll check on the grounding although I think it's ok.

Hey guys thanks. It's unusual for a newly reconstructed alt. to be a lemon but ithappens. I'llhave thenext one checked before

it's mounted . Have a good one!
Leslie
Reply With Quote
  #5  
Old 10-05-2008, 08:25 AM
Junior Member
 
Join Date: Sep 2008
Posts: 6
Default RE: ALTERNATOR 940

jsinton & tech: just thought of something that might help. The battery light does not come on so I had no idea that the alt. was

not charging. Does that info help? I had the car's battery and alt. testedfor performance and that's howI found the problem.

leslie
Reply With Quote
  #6  
Old 10-05-2008, 08:45 AM
tech's Avatar
Administrator
 
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,443
Default RE: ALTERNATOR 940

Alot of times the light will not come on a bad design from Volvo.
__________________
1987 Ford mustang LX Coupe 5.0
1995 Yellow T5-RM running
1996 850 turbo
1994 N/A 5-speed wagon Purple (daughters)
Reply With Quote
  #7  
Old 10-09-2008, 07:42 AM
Junior Member
 
Join Date: Sep 2008
Posts: 6
Default RE: ALTERNATOR 940

jsinton,tech: I've narrowed the problem down to the regulator. w/o the A/C or headlights the reading for voltage is app. 13.5 v.

W/A/C on, the voltage drops.[&:] Leslie
Reply With Quote
  #8  
Old 10-09-2008, 09:08 AM
Junior Member
 
Join Date: Oct 2008
Posts: 22
Default RE: ALTERNATOR 940

You're still not telling us how you know it's not charging. Does the battery go dead?

The regulator is in the alternator.
[align=left] [/align]
Reply With Quote
Old 10-09-2008, 09:08 AM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 02:38 PM.
© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.
Secure Backup