Shift Problem - Volvo AW55-50 Series Transmission - Volvo Forums - Volvo Enthusiasts Forum


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-12-2017, 10:38 AM
Senior Member
Thread Starter
 
Join Date: Nov 2006
Location: Birmingham AL
Posts: 277
Default Shift Problem - Volvo AW55-50 Series Transmission

A few years back, I posted a solution to the shifting problems that most of you experience with the AW55-50 transmissions (5-speed automatics) that are installed in your vehicle. Typically any Volvo 5-cylinder engine has this transmission.

I was met with a firestorm of miscreants, know-it-alls, and screwballs who, with only a seat of the pants reference, attempted to discredit my suggestions. So, I went dormant on this site and basically made a fortune fixing Volvos with "bad transmissions".

As a licensed dealer and shop owner, I have a lot more exposure to cars and have fixed MANY Volvos to date. The highest mileage unit is one that we have for sale right now, an 06 XC70 with 185k miles. Fluid change, solenoid change and computer adaptation/relearn have made all of these cars shift like new. The transmissions themselves are very durable, they just need solenoid changes when they start shifting hard.

If you are interested in learning more, contact me via PM and I'll give you the overview. For those who have other opinions, I would venture to say that I have fixed more of these than anyone else with 100% positive results so far. Now, if the transmission is slipping, forget it, you need a rebuilt unit.
Reply With Quote
  #2  
Old 03-18-2017, 11:50 AM
Member
 
Join Date: Oct 2012
Posts: 58
Default

Hi Tony,

Glad to see you're back. I recall that thread several years ago and just couldn't understand people's attitudes.

I had a 2003 V70 2.5T with AWD. I read a lot of posts on these transmissions and am familiar with the B4 servo, etc. I changed the AT fluid at 50K and 100K miles. Tranny worked great. Then a few weeks ago at 140K miles it got hit and was totaled.

This morning I test drove a 2008 XC70 with 114K miles. Once or twice on surface streets there was a funky/bump when shifting from 2nd to 3rd. Definitely not all the time though. I did not detect any slipping. I don't know exactly which trans is in this car but, it is a 6 speed, not 5 speed.

Any thoughts? Would a fluid drain and refill possibly remedy this?

Many thanks sir

Bob
PS: there is a trailer hitch on the car but, could not tell if it was used frequently

Last edited by RJSV70; 03-18-2017 at 11:52 AM.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
having AW55-50SN AF33-5 issues put afilter in cooler line tvjeff General Volvo Chat 1 05-30-2015 11:01 PM
Valve body AW55-50SN Vetacosa1 2001-2013 model year V70 0 03-04-2015 08:49 AM
2000 XC70 transmission AW55-50 replacement tr_car_nut Volvo XC70 0 07-03-2011 09:02 AM
What happens when you put AW50-42 ATF into an AW55-50SN transmission? teaberry Volvo C70 9 01-29-2011 05:12 PM
1981 240dl is automatic trans aw55 or bw55? sephirothnick Volvo 240, 740 & 940 0 02-21-2008 01:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:02 AM.