Audio/Visual Electronics Wired up? Everyone's got some sort of electrical modification. let's hear about it here.

BluePower BLP-890 gps causing climate control issues?

  #1  
Old 10-20-2009, 10:37 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Posts: 21
Question BluePower BLP-890 gps causing climate control issues?

Hello all, I just bought the BluePower BLP-890 and I just finished installing it, but now my rear defrost, and heated seats buttons on the actual climate control panel don't work. The heated seats are now permanetly on unless I remove the fuse (because the buttons don't work to turn them off, they're not even lit up, nor function.) Also when I press the rear defrost button (even though it's not functioning, or lit up, I hear a clicking in the back when I press the rear defrost button.)I wasn't sure why this was happening, so I checked all of the fuses and they were all fine. I even went out and looked for a new climate control panel, found one and spent nearly a $100 on it, and it did not fix the problem.I'm not sure what to do, has anyone heard of this problem, is it even the BluePower HU? Please, if anyone can help, it is already in the 40's in Chicago, and the rear defrost does not currently work. Thanks so much in advance,BrianP.S. I don't really want to go back to the stock unit.
 
  #2  
Old 10-20-2009, 04:06 PM
Senior Member
Join Date: Dec 2008
Posts: 425
Default

Let's start by naming year and model of your vehicle. Describe in detail your installation since we are under the impression all your problems occurred after the install.
 
  #3  
Old 11-02-2009, 07:54 PM
imhereftw's Avatar
Senior Member
Join Date: Jan 2009
Location: Maryland, USA
Posts: 179
Default

I'm assuming you did the install your self?
 
  #4  
Old 11-03-2009, 07:36 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Posts: 21
Default

Originally Posted by mkc70 View Post
Let's start by naming year and model of your vehicle. Describe in detail your installation since we are under the impression all your problems occurred after the install.
2001 S60 -I did the install myself, to start off with.I took out the climate control, then the stock HU.I then did the install of the BluePower unit, I also hooked up their ipod cable, and their gps antenna. I am pretty sure I hooked up everything correctly! I then hooked the climate control back up, started my car, to test it out, and that's when I noticed that the lights were no longer on the rear defrost, or the heated seats. When I push the heated seats buttons, I get nothing, no lights or anything. The heated seats are permanently on, unless the fuses are removed.The rear defrost button when pushed makes a clicking sound in the back seat, but it does not come on or stay on automatically like the heated seats. I have also noticed one more problem, the mirrors used to be heated, and I think they no longer work from this climate control issue?If you need any other info, please reply.Thanks,Brian
 
  #5  
Old 11-03-2009, 08:30 AM
imhereftw's Avatar
Senior Member
Join Date: Jan 2009
Location: Maryland, USA
Posts: 179
Default

Try calling blue power, they may be able to help assuming that they have English speaking customer support :P
 
  #6  
Old 11-03-2009, 09:32 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Posts: 21
Default

Originally Posted by imhereftw View Post
Try calling blue power, they may be able to help assuming that they have English speaking customer support :P
I contacted them and they said "they have never heard of this problem."
 
  #7  
Old 11-03-2009, 09:34 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Posts: 21
Default

Originally Posted by mkc70 View Post
Let's start by naming year and model of your vehicle. Describe in detail your installation since we are under the impression all your problems occurred after the install.
Forgot one thing... There was no need for any wiring harness either. These HU are made specifically For Volvo.
 
  #8  
Old 11-04-2009, 11:56 AM
Senior Member
Join Date: Dec 2008
Posts: 425
Default

Originally Posted by twistab4pudd View Post
Forgot one thing... There was no need for any wiring harness either. These HU are made specifically For Volvo.
Did you disconnect the battery before you removed climate control?
 
  #9  
Old 11-05-2009, 07:55 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Posts: 21
Default

Originally Posted by mkc70 View Post
Did you disconnect the battery before you removed climate control?
The first time, I did.... The second time, I didn't.
 
  #10  
Old 11-06-2009, 11:21 AM
Senior Member
Join Date: Dec 2008
Posts: 425
Default

Originally Posted by twistab4pudd View Post
The first time, I did.... The second time, I didn't.
Get a code reader and see if any codes pop up. Next if necessary reinstall factory radio. Need to see if the problem is related to the install, or just a coincidence. Keep us posted.
 
  #11  
Old 04-09-2010, 09:59 AM
Junior Member
Thread Starter
Join Date: Mar 2009
Posts: 21
Default

Originally Posted by mkc70 View Post
Get a code reader and see if any codes pop up. Next if necessary reinstall factory radio. Need to see if the problem is related to the install, or just a coincidence. Keep us posted.
Ok, still having this problem! I took my car to the Volvo dealership earlier this week and they did a diagnostics on my car. They found nothing, no codes that had to do with it. I have also noticed that even though the heat seaters and rear defrost lighted controls on the panel don't light up when pushed, if i push them the heated seats and rear defrost do work, the controls on the panel just don't light up!? I also have the same problem with another climate control panel I bought, thinking it would fix my light issues on those controls. But I thought wrong. What could be the problem here? The controls work on both panels I have tried, but they don't light up on either panel? I don't get it. Do you think the after market HU could be missing a certain conection to light that part up? The HU doesn't even hook up to the climate control panel, it just plugs into the stock Volvo harness, so I don't get why it is causeing this problem. Fuses are fine, could it be a relay? or is there something under the hood I could check?Any help would be greatly appreciated. Brian
 
  #12  
Old 04-18-2010, 05:26 AM
Junior Member
Join Date: Apr 2010
Posts: 6
Default

Art - This is excellent news. I have been exploring aftermarket options and none as nice as this. Recognizing that IPD will sell it, who would you reccommend in Edmonton/ AB to install such a unit. Not withstanding the obvious answer being me. I have seen the work you have done on your own car, i don't trust myself with electronics.
____________________________________________
Woodworking Plans
Steak London
 
  #13  
Old 04-18-2010, 10:34 PM
Banned
Join Date: Apr 2010
Posts: 6
Default

Art - This is excellent news. I have been exploring aftermarket options and none as nice as this. Recognizing that IPD will sell it, who would you reccommend in Edmonton/ AB to install such a unit. Not withstanding the obvious answer being me. I have seen the work you have done on your own car, i don't trust myself with electronics.
_________________________________________________
increase stock volume
employee benefit management
 
  #14  
Old 05-18-2010, 05:41 AM
Banned
Join Date: Apr 2010
Posts: 6
Default

Art - This is excellent news. I have been exploring aftermarket options and none as nice as this. Recognizing that IPD will sell it, who would you reccommend in Edmonton/ AB to install such a unit. Not withstanding the obvious answer being me. I have seen the work you have done on your own car, i don't trust myself with electronics.
==========================
Breast Augmentation Breast Enlargement
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jcedor
Volvo 240, 740 & 940
1
07-08-2015 11:10 AM
mhop3420
2001-2013 model year XC70
2
01-06-2015 06:25 PM
bubba240
Volvo 240, 740 & 940
2
01-16-2010 11:57 PM
jfikentscher
Volvo 850
4
05-31-2006 09:58 PM
vict8r
Volvo 850
1
10-26-2005 01:04 AM


Thread Tools
Search this Thread
Quick Reply: BluePower BLP-890 gps causing climate control issues?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.