1992 240 rough idle and stalling - code 2-3-2

  #1  
Old 11-21-2011, 08:03 PM
Junior Member
Thread Starter
Join Date: Nov 2011
Location: New England
Posts: 3
Default 1992 240 rough idle and stalling - code 2-3-2

I have a 1992 240 with about 130K for mileage. I have owned the car since it was new and have done the majority of the work on the car. Anything I can do without a lift, I try to do myself.

The car has been running rough when first started. Once it gets up to temp it is running like clockwork. But the 10 minutes while it warms up it runs rough and hesitate when I step on the gas.

Replaced all ignition wiring, distributer and cap when is first started.

No check engine light.

I got code 2-3-2, "Fuel system compensating for rich or lean mixture at idle". I am trying to rule out the possibilities. I believe it is the coolant temp sensor. Hoping it is not the Idle Air Control Valve.

Any thoughts or experience would be appreciated. I can do any testing I need before buying parts, as these are all expense parts that seem to be in play for this problem.
 
  #2  
Old 11-21-2011, 10:12 PM
swiftjustice44's Avatar
Super Moderator
Join Date: Aug 2008
Location: Dallas, TX
Posts: 2,581
Default

Did it run poorly when first started during the summer? How about warm/hot restarts, such as when running errands? Just the first start of the day? It isn't the IAC; that really just affects the idle rpm, not the quality. I believe by 92 they had done away with the cold start injector...I know 93's did not have them. W/o a cold start 5th injector, engine coolant sensors play an even bigger part in cold starts. A lot depends on what maintenance has been done recently. Quite honestly, often a number of items can be operating at low normal and the combined result is poor performance. For instance, worn/fouled plugs don't fire well when cold. A leak in the exhaust will make a functioning O2 sensor think the mixture is lean and tell the ecu to richen the mixture which fouls the plugs. Bad plug wires, worn rotor and cap...all will tell their tale as the weather cools off.
So, my question is: Where are you with service on the car? That dictates a lot as to where to go from here.
 
  #3  
Old 11-22-2011, 05:53 AM
Junior Member
Thread Starter
Join Date: Nov 2011
Location: New England
Posts: 3
Default

I have done most of the maintenance on the car. So I know what has been done.

The problem is fairly recent, so this summer all seemsed well. The problem is only an issue when the car is cold, or has cooled down. If the car is warm and I runa quick errend the car is fine on start up. Once it reached temp all is well.

I have just replaced the rotor, distributer cap and all ignition wiring in the last month. The exhaust had a leak in the manifold, but I took it to a shop to get repaired 3 weeks ago. So the exhuast is tight now. Plugs have not been done in about 3 years.
 
  #4  
Old 11-22-2011, 06:16 AM
swiftjustice44's Avatar
Super Moderator
Join Date: Aug 2008
Location: Dallas, TX
Posts: 2,581
Default

Well, then, sounds like it may indeed be the ecs. Here's a decent diagnostic write up...
http://www.swedishbricks.net/700900F...e Sensors, Etc
 
  #5  
Old 11-25-2011, 03:12 PM
Junior Member
Thread Starter
Join Date: Nov 2011
Location: New England
Posts: 3
Default New Codes

I have some new codes that have registered on the car. The check engine light came on, and I now have 3 codes.

2-3-2 Fuel system compensating for rich or lean mixture at idle
2-3-1 Fuel system compensating for rich or lean mixture at cruise
2-2-1 Fuel system compensating for extreme rich or lean mixture at cruise

I have not changed out the coolant temp sensor yet. Do you think these same codes are evidence of a single problem with the ECS?
 
  #6  
Old 11-25-2011, 05:13 PM
swiftjustice44's Avatar
Super Moderator
Join Date: Aug 2008
Location: Dallas, TX
Posts: 2,581
Default

Well, before you replace, diagnose...this article concerns the 7 series, but the motor is the same as yours...
http://www.swedishbricks.net/700900F...e Sensors, Etc
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
coolhandluke7791
Volvo 240, 740 & 940
1
04-30-2015 02:07 AM
T4paul
Volvo S40
10
11-24-2013 12:25 AM
xDread92x
Volvo 240, 740 & 940
10
07-01-2013 04:55 PM
ocvolvo940t
Volvo 240, 740 & 940
15
09-23-2009 08:40 PM
~ViciousVolvo~
Volvo 240, 740 & 940
1
04-09-2008 06:41 PM


Thread Tools
Search this Thread
Quick Reply: 1992 240 rough idle and stalling - code 2-3-2


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.