Volvo 850 Made from 1993 to 1997, this Volvo line was available in both a wagon and a sedan, both with were graced with several trim levels.

Starting issue

  #1  
Old 10-22-2017, 03:20 PM
Senior Member
Thread Starter
Join Date: Jun 2012
Location: Sonoma County, California
Posts: 467
Default Starting issue

I let my car site for a few weeks and the battery went dead. I tried jumping it but no luck so I took the battery out and recharged it but when I turn on the key all I get is the lights on the instrument cluster but no crank & no fuel pump sound. The start signal is not getting to anything. After the key switch where does the signal go? Does it go to a relay to tell everything to start happening or what?
Side note, as soon as I turn on the ignition I can hear a relay click and also the emergency flashers start flashing.
 

Last edited by Phil 850; 10-22-2017 at 05:47 PM.
  #2  
Old 10-22-2017, 06:39 PM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,782
Default

did you measure the voltage of the battery? its possible it has a dead cell... You have relays for fuel pump and fuel injectors but the starter also has the immobilizer and the computer in play. Low voltage will mess with the computer.
 
  #3  
Old 10-22-2017, 08:27 PM
Senior Member
Join Date: May 2012
Location: Kingsport, TN
Posts: 1,513
Default

If the hazards are flashing, I think you are in "security immobilizer" mode. You can check that for free, of course. Just lock and unlock the door a few times with the key and see if you get anywhere that way.
 
  #4  
Old 10-23-2017, 07:12 PM
Senior Member
Thread Starter
Join Date: Jun 2012
Location: Sonoma County, California
Posts: 467
Default

Originally Posted by firebirdparts View Post
If the hazards are flashing, I think you are in "security immobilizer" mode. You can check that for free, of course. Just lock and unlock the door a few times with the key and see if you get anywhere that way.
I keep forgetting about that, thanks for the reminder. I went out and reconnected the battery then locked and unlocked the car twice and then it started right up.
Thank you
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
huey3110
Volvo S40
7
12-16-2016 06:06 AM
JasonCase
Volvo V70
1
03-11-2007 01:46 PM
Anns V70
Volvo V70
0
02-13-2007 10:40 AM
Jdub
Volvo S80
1
08-30-2006 09:48 PM


Thread Tools
Search this Thread
Quick Reply: Starting issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.