C30 Misfire on Startup - Volvo Forums - Volvo Enthusiasts Forum

Volvo C30 This compact hatchback gives a sporty feel without compromising versatility.

C30 Misfire on Startup

  #1  
Old 06-21-2018, 10:40 AM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 2
Default C30 Misfire on Startup

2008 Volvo C30 1.0 T5 with 130k miles.
On cold startup the car runs rough bouncing between 1500-2000 rpm for about 10 sec before returning to 1500 until it is warm, the following codes have appeared: P0101 MAF circuit range/performance, and P0300 Random/ Multiple cylinder misfire. I have taken the following steps to solve the issue:

About a year ago Cylinder 3 coil pack was replaced due to P303 code (issue was solved, just added as background)
New MAF sensor was installed (after attempting to clean the stock Bosch unit, which also didnít stop the code from reappearing) 2 weeks ago
All 5 spark plugs replaced with Bosch units (3 months ago)
New air filter, which was installed at the same time as the spark plugs

The MAF problem started about a month ago, but the rough idle only 2 weeks ago, even after clearing the codes, they return after 1 or 2 driving cycles. Rough start up even happens after codes are cleared.

Anybody had this issue, or have any advice as to what the next steps should be?
 
  #2  
Old 06-21-2018, 12:41 PM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,305
Default

are you still getting the P030X codes? did you also try cleaning the throttle body / idle air controller etc? I'd also be curious about measuring the fuel pressure and test for possible intake air leaks which can force the MAF to go out of range (meaning it can't compensate enough for the ECU's input).
 
  #3  
Old 06-21-2018, 12:49 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 2
Default

yes i am still getting P0303 primarily and then over time if i don't clear it, it will change to a P0300 code, had the oil trap/PCV valve replaced a few thousand miles ago(when the telltale whistling started), but if i open the oil cap it does increase idle and pull a slight vacuum on my hand, but not a massive force, I am not sure what to look for.

I was going to check the throttle body tonight and see if that is dirty as well.

There is an occasional "very small evaporative leak" code P456 that comes up occasionally, but i attributed that to a leaky gascap, but it still pops up.

would replacing the fuel filter be advised?
 
  #4  
Old 06-23-2018, 12:17 PM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,305
Default

not likely the fuel filter, in fact your car may not even have a fuel filter! (some models simply have an in tank screen).
 
  #5  
Old 06-24-2018, 10:51 AM
Senior Member
Join Date: Nov 2006
Location: Birmingham AL
Posts: 1,502
Default

The misfire is likely caused by an overly lean mixture. The problems that you are describing point toward either an intake air leak or a bad mass airflow sensor.
 
  #6  
Old 01-18-2019, 03:19 PM
Junior Member
Join Date: Jan 2019
Posts: 1
Default

Hello, I read what's happening to your c30 and I'm having the exact same problem. I haven't been able to fix the problem. I've taken similar steps replacing spark plugs and coil packs with no luck. Where you able to find the problem. My next step is to smoke test the intake system for leaks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ccsturgi
Volvo C30
0
10-31-2017 07:34 PM
oracleminded
Volvo XC70
1
09-17-2012 07:50 PM
jdbs3
Volvo 240, 740 & 940
3
02-03-2009 05:11 AM
dtupac
Volvo 240, 740 & 940
4
07-22-2007 05:47 PM


Thread Tools
Search this Thread
Quick Reply: C30 Misfire on Startup


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.