Volvo S40 The S40 is Volvo's most affordable sedan with all the amenities of a luxury sports car.

Sputtering in R and D

  #1  
Old 10-30-2009, 03:15 AM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 6
Default Sputtering in R and D

While accelerating to pass another vehicle, my '01 S40 started sputtering badly and the CEL came on. I had just replaced the spark plugs a couple days before in response to some minor sputtering issues i was having so i was pretty sure it wasn't plugs.

I bought a code reader and the reading came back p0303 (cylinder 3 misfire), p0700 (Transmission control system malfunction), and p0705 (transmission range sensor circuit malfunction).

I've read almost all of the posts pertaining to sputtering and the general consensus is Plugs, Coils, Wires.

I replaced the coil for cylinder 3 and i'm still having the sputtering issue but only while in R or D. i'm only getting the p0303 code now though

do i need to replace all of the coils, or just the one for the cylinder that's misfiring.

is it significant that the sputtering is only in drive modes?
 
  #2  
Old 10-30-2009, 03:23 PM
AutoNaut's Avatar
Senior Member
Join Date: Oct 2009
Location: MD
Posts: 747
Default

That still sounds ignition related. What engine do you have and what plugs (brand and model#) did you install?

Did you verify the proper gap and torque them to spec?
 
  #3  
Old 10-30-2009, 03:58 PM
Lyonsroar's Avatar
Senior Member
Join Date: Jun 2008
Location: Omaha, NE
Posts: 688
Default

You can switch the new coil over to the other set of cylinders and see if your misfire cylinder changes.
 
  #4  
Old 10-30-2009, 04:19 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 6
Default

1.9L 4 cylinder turbo w/ about 64000 miles

i used bosch platinum +

they arent torqued to spec though
 

Last edited by exceter474; 10-30-2009 at 04:56 PM.
  #5  
Old 10-30-2009, 05:05 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 6
Default

I switched the new coil over to cylinder 4 and kept the wires in the same position but that didn't seem to accomplish anything. However, when i rearranged the wires so that they matched up to the coil switch (1-4 <--> 2-3) the sputtering issue was alleviated somewhat. now it doesn't sputter anymore while idling, but it does still sputter if i accelerate with anything more than a light depression of the gas pedal.

Any thoughts?
 
  #6  
Old 10-30-2009, 06:36 PM
Lyonsroar's Avatar
Senior Member
Join Date: Jun 2008
Location: Omaha, NE
Posts: 688
Default

Originally Posted by exceter474 View Post
I switched the new coil over to cylinder 4 and kept the wires in the same position but that didn't seem to accomplish anything. However, when i rearranged the wires so that they matched up to the coil switch (1-4 <--> 2-3) the sputtering issue was alleviated somewhat. now it doesn't sputter anymore while idling, but it does still sputter if i accelerate with anything more than a light depression of the gas pedal.

Any thoughts?
Did it throw a different code?
 
  #7  
Old 10-30-2009, 06:38 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 6
Default

now i'm showing a new code: P0352 (coil b primary/secondary circuit malfunction)

What is this?
 
  #8  
Old 10-31-2009, 11:06 AM
Lyonsroar's Avatar
Senior Member
Join Date: Jun 2008
Location: Omaha, NE
Posts: 688
Default

Originally Posted by exceter474 View Post
now i'm showing a new code: P0352 (coil b primary/secondary circuit malfunction)

What is this?
You need another new coil I think.

P0352 Ignition Coil B Primary/Secondary Circuit Malfunction
 
  #9  
Old 11-04-2009, 04:48 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 6
Default

installed new volvo spark plug wires. still only the one new coil on three. tried to drive but the engine sputtered and died on me.

opened the car back up and noticed the electrical plug on coil 3 looks pretty tore up. i think the electrical plug needs replacement too.

Got the car running again but now its idling strangely in P. it'll idle at 1200 and gradually slow down to 800, and then start sputtering around 800, then jump right back up to 1200. Is anyone familiar with this issue?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
miless1944
Volvo 240, 740 & 940
18
12-28-2010 06:01 PM
W35
Volvo S70
1
02-27-2009 10:00 PM
78vovlo244
General Volvo Chat
0
02-13-2009 01:06 AM
Chad G
Volvo S60 & V60
13
10-07-2008 08:12 AM
troche
Volvo S40
7
05-03-2006 09:12 PM


Thread Tools
Search this Thread
Quick Reply: Sputtering in R and D


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.