Car Won't Start After Running Hot - Volvo Forums - Volvo Enthusiasts Forum

Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S70
Reload this Page >

Car Won't Start After Running Hot

Volvo S70 Made from 1998 to 2000, this sporty model replaced the 850 sedan and instantly became a hit.

Car Won't Start After Running Hot

Reply

 
 
 
  #1  
Old 12-04-2017, 12:49 PM
Junior Member
Thread Starter
Join Date: Dec 2017
Posts: 1
Default Car Won't Start After Running Hot

Long story short found a leak in radiator got it replaced than later found out I needed a new coolant temp sensor because of still leaking afterwards of New Radiator so I was driving started smoking from hood and exhaust of white smoke pulled over to cool off and now won't crank I Had to get it towed its a 2000 volvo s70 189000 miles any suggestions and fixes also While I was driving I press the gas I heard a rattling noise when press accelerate which also prompt me to pull over and I up hood and seem like oil was pressured and sprayed on some parts
 
Reply With Quote
  #2  
Old 12-04-2017, 06:18 PM
Senior Member
Join Date: May 2012
Location: Kingsport, TN
Posts: 1,334
Default

Sounds like the head gasket failed.
 
Reply With Quote
  #3  
Old 12-05-2017, 08:45 AM
Psaboic's Avatar
Super Moderator
Join Date: Jan 2006
Location: SW, WA
Posts: 2,177
Default

Yep.....betting on a head gasket
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ibified
Volvo 850
22
09-12-2012 12:24 AM
buckthedog
Volvo 240, 740 & 940
8
07-03-2010 10:28 PM
Kaybihiak
Volvo 240, 740 & 940
1
12-01-2007 11:03 PM
beardo265
Volvo V70
5
09-27-2007 09:24 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory