Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

01 vOLVO S80 2.9 ROUGH IDLE LOSS OF POWER

  #1  
Old 08-23-2018, 04:32 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Exclamation 01 vOLVO S80 2.9 ROUGH IDLE LOSS OF POWER

Hello everyone, i have a 2001 Volvo s80 with 112k miles on it. one day as i was driving it check engine light came on got the code read and i got two codes. one for o2 sensor and a p0300 (random miss fire). when the car is in park it shakes, has a "boom boom boom'' noise coming from exhaust( guessing its the miss fire) revs up normally. The big problem is when car is put into gear it shakes even harder and will rev up to 3,000 rpm but car wont move even though it has grabbed the gear. i have checked spark plugs all but one were good the one smelling and being drenched in left over gas. i changed ignition coils, spark plugs, 02 sensor and cvvt. turned car back on still does the same thing. no service message shows up on dash.can someone please help.
 
  #2  
Old 08-23-2018, 05:00 PM
Senior Member
Join Date: Nov 2006
Location: Birmingham AL
Posts: 1,502
Default

Is this the twin turbo model by chance?
 
  #3  
Old 08-23-2018, 05:03 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default

no it is a non turbo
 
  #4  
Old 08-23-2018, 05:57 PM
Senior Member
Join Date: Nov 2006
Location: Birmingham AL
Posts: 1,502
Default

I know that the oxygen sensors on this model will cause a rough running engine. The one that I recalled was a twin turbo and it had an oxygen sensor in each exhaust manifold. Basically Volvo engineered two inline 3-cylinder engines.

Start with the oxygen sensor. That is probably your problem. I hope it is the upstream sensor since the downstream sensor requires removing the catalytic converter to change.
 
  #5  
Old 09-06-2018, 09:33 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default New issue

Sorry for not updating post but i have changed o 2 sensor turned car on and still could hear and got same misfiring including power loss when in gear. i did some research and concluded i was going to reset my ecu once followed given procedures of removing ecu and putting it back ect... the car now only cranks but engine wont turn on.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Wesley brown
Volvo 260, 760 & 960
5
10-07-2014 10:12 AM
iamnickcarter
Volvo 240, 740 & 940
11
07-25-2012 03:23 PM
Darin Schroeder
Volvo XC90
0
07-06-2012 08:53 PM
hoodoo262
Volvo S60 & V60
1
05-15-2010 04:49 PM
markjenross
Volvo V40
0
09-29-2007 09:29 AM


Thread Tools
Search this Thread
Quick Reply: 01 vOLVO S80 2.9 ROUGH IDLE LOSS OF POWER


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.