Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

1999 S80, electrical mystery...!

  #1  
Old 09-11-2012, 10:17 AM
Junior Member
Thread Starter
Join Date: Sep 2012
Posts: 1
Default 1999 S80, electrical mystery...!

I have a 1999 volvo s80 T6, 2.8. About a month ago I went away for a couple of weeks, gave a family member the keys to run it every few days. Came back and the car wouldn't start, the battery was dead (car alarm flash lights had went off one night and the battery drained). I replaced the battery with a rebuilt one, was fully charged and in good working condition. Soon after that I started having the following problem:
Car all sudden wouldn't start, cranks, theres power but wouldn't start until after a few tries and waiting on it a few minutes.
When it does start, sometimes it doesn't start or run normally, what I mean by that is: dashboard (odometer, speedometer, temp, gas all stop working n get zerod out), car feels very rough (rough idle, as if its running on high rpm and feels like its dying out at times) .
Changed the spark plugs, didn't help.
Volvo mechanic put on scanner, no relevant codes showed up, said it might be the instrument cluster? But I.doubt that it is, since the problem is more then the display gages.

my temporary solution has been disconnecting n reconnecting the battery, which seems to reset the electrical issue. The negative battery cable is loose, will need to change it because its not tightening well.


Whats your take on this.....

Thank you

Whats your take on this??
Thank you [/quote]
 
  #2  
Old 09-11-2012, 05:40 PM
Senior Member
Join Date: Apr 2009
Posts: 464
Default

Change neg cable FIRST.
Rebuilt battery? Never heard of that. Look for vacuum lines that you may have knocked off/cracked.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HoundWisper
Volvo 240, 740 & 940
8
12-08-2013 01:06 AM
xpiecemealx
Volvo 850
33
11-09-2010 08:56 AM
nsimha
Volvo V70
7
08-11-2007 07:36 PM
jonemory
Volvo 260, 760 & 960
3
02-04-2007 05:29 PM


Thread Tools
Search this Thread
Quick Reply: 1999 S80, electrical mystery...!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.