Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

1999 S80 "limp mode"

  #1  
Old 10-23-2009, 01:31 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 2
Default 1999 S80 "limp mode"

About 5 weeks ago, our S80 started sporatically losing power where it would not go above 20 miles an hour and 2000rms. Took it in and they stated that it needed a new Throttle Positioning Sensor. Had the throttle body replaced, and just took it in to have the ECM (software updated). On the way home from the dealer, it started doing it again. The Transmission light is on, and they stated that the Cylinoid for the transmission is bad. Would this cause the car to go into "limp mode"?? Is it fixable or does the tranny need to be replaced? THANKS for the help!
 
  #2  
Old 10-23-2009, 04:40 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 2
Default Would a bad 02 sensor make a car go into Limp Mode?

I got a p0136 and p0036 code. Which is O2 sensor. Also they told me that the TCM-0092 Solenoid Park/neutral switch is bad. Could either of these issue make the car go into LIMP MODE?
 
  #3  
Old 10-23-2009, 04:40 PM
Lyonsroar's Avatar
Senior Member
Join Date: Jun 2008
Location: Omaha, NE
Posts: 688
Default

Moved to S80 chat.
Please post in the correct subforum next time.
 
  #4  
Old 10-23-2009, 07:17 PM
Lyonsroar's Avatar
Senior Member
Join Date: Jun 2008
Location: Omaha, NE
Posts: 688
Default

No double posting please.

Your earlier thread is right here:
https://volvoforums.com/forum/showthread.php?t=35702

This is the "general volvo chat" your inquiry belongs in the S80 subforum.
 
  #5  
Old 10-26-2009, 08:45 AM
Super Moderator
Join Date: Aug 2005
Location: Elizabethtown, Kentucky
Posts: 4,244
Default

Threads merged by mod.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sugardoo
Volvo S60 & V60
0
10-16-2013 02:05 PM
TJVolvo
Volvo S80
3
03-14-2013 04:20 AM
RedTurbo850
Volvo 850
7
02-26-2007 10:22 PM
swede850T
Volvo 850
2
07-04-2005 03:44 PM


Thread Tools
Search this Thread
Quick Reply: 1999 S80 "limp mode"


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.