Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

1999 S80 T6 with voltage/electrical issue

  #1  
Old 12-12-2013, 01:32 PM
Junior Member
Thread Starter
Join Date: Dec 2013
Posts: 1
Default 1999 S80 T6 with voltage/electrical issue

Howdy ya'all,

So, I have had my S80 for about 6 months now, and over all it has been a great vehicle. I have recently encountered an issue that has me scratching my head. I need to do some diagnostics, but it's the holidays, I am a college student and cash is tight! So I figured I would drop this into a forum and see what any of you might have to say about it.

So, a week or so ago the battery light came on, but usually after running for a bit it went away. I figured it might have something to do with me running the seat warmers for the first time. But no issues arose. Usually after driving for a few minutes the light went out. Oh, and the read out on the control panel said elec syst maintenance needed, I think...

Then a few days ago I had been driving for a good 15-20 minutes, and a whole bunch of system warnings came on... ABS, traction control, check engine, etc, along with the battery light. And then she started shutting down on me. Not suddenly. She drove oddly for a bit, lurching and having erradic acceleration, and then no power at all, and then she finally just died. As far as I could see, none of my lights were dimming and there did not appear to be any of the classic indicators that my alternator was not supplying power.

Fast forward to yesterday where after I have it towed home, a buddy comes by, we jump it, and it starts right up. I decide to let it run for a bit to see what happens, and sure enough after a few minutes it starts doing the same thing, losing power and slowly shutting down.

So, first thought; it has a pretty expensive and new battery in it that I got from auto zone. 3 year warranty style. But I have also had 2 other batteries from auto zone go to hell on me in 6 months. Maybe the battery is crap? My first thing will be to take that in a and get it tested to see.

Second though is alternator/alternator brushes. Not sure what anyone's experience here is with how these die or when, but that was another thought.

Another thing I saw here and there through digging around on the web was stuff about the voltage regulator. I have no experience in these going bad, so I do not know any tell-tale symptoms.

A bit more about the car. Good condition. 186k on it. She has run like a top until this. she has an odd thing with having to have the ignition in just the right spot or much of the electrical will not operate, like radio, moon roof, lights, etc, but she starts right up no problem.

Any and all input and/or advice would be greatly appreciated! I have done lots of auto work on my cars in the past. Anything from exhaust and mechanical, drive train on up to top end engine work and valve jobs, but I have never owned a volvo before, so I am in virgin territory! So looking for some sound advice! Thanks in advance for anything you got! Cheers and happy holidays!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
worldbound4now
Volvo V70
6
04-15-2015 05:14 PM
InNomina
Volvo V70
0
10-15-2010 02:03 PM
artemis_f0wl
Volvo S60 & V60
3
04-30-2009 06:58 PM
red_t5
Volvo 240, 740 & 940
1
03-31-2009 04:15 AM
Business_Socks
Volvo S60 & V60
1
02-02-2009 05:50 PM


Thread Tools
Search this Thread
Quick Reply: 1999 S80 T6 with voltage/electrical issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.