Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

2000 S80 non- turbo, crazy idle???

  #1  
Old 02-21-2011, 09:09 AM
Junior Member
Thread Starter
Join Date: Feb 2011
Posts: 10
Default 2000 S80 non- turbo, crazy idle???

It never does this till it warms up. And sometimes it stops for awhile once its been driven some.
Here's what its doing. At idle in park or in gear, it will drop from 700 rpm down to 500 rpm to the point of almost stalling, dash lights/headlights dim the whole 9 yards.
I thought it was a vacuum leak, but darned if I can find it.
It doesn't run particularly rough when being driven. Slight lack of power maybe??
Its my wife's car so I don't drive it often enough to know for sure.
Any idea's on what could be causing this??

Thanks
Jamie.
 
  #2  
Old 02-21-2011, 03:15 PM
Senior Member
Join Date: Jul 2009
Posts: 275
Default

It might be the ETM. Has it been replaced with a new one under warranty?
 
  #3  
Old 02-21-2011, 05:26 PM
Junior Member
Thread Starter
Join Date: Feb 2011
Posts: 10
Default

I'm really not sure. We bought it used. I don't think we've replaced it though.
 
  #4  
Old 02-22-2011, 09:38 PM
mustang's Avatar
Member
Join Date: Jan 2010
Posts: 63
Default

a buck says it's your ETM. perhaps it's defective or just dirty

here's a vid on how to clean it

http://www.youtube.com/watch?v=8Zaxtm-hdyo

hope it helps
 
  #5  
Old 02-23-2011, 08:59 AM
Junior Member
Thread Starter
Join Date: Feb 2011
Posts: 10
Default

Originally Posted by mustang View Post
a buck says it's your ETM. perhaps it's defective or just dirty

here's a vid on how to clean it

http://www.youtube.com/watch?v=8Zaxtm-hdyo

hope it helps
Great video! Thanks. That's exactly how here car is running. I'm going to try and clean it and see what happens. Hopefully that'll. Do it though.

Thanks again.

Jamie.
 
  #6  
Old 02-23-2011, 09:04 PM
Junior Member
Join Date: Aug 2010
Location: PA
Posts: 9
Default

could also be an o2 sensor.... its worth a check
 
  #7  
Old 03-03-2011, 03:13 PM
Junior Member
Thread Starter
Join Date: Feb 2011
Posts: 10
Default

Originally Posted by 300zx_tt View Post
could also be an o2 sensor.... its worth a check
Man, I hope not she had 4 of those replaced last year.
 
  #8  
Old 03-05-2011, 05:11 PM
Junior Member
Thread Starter
Join Date: Feb 2011
Posts: 10
Default

Yep, the ETM was really dirty. Cleaned it up, and she's running like a new car!!
Thanks again for the video link.

Jamie.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ablorx
Volvo S70
1
07-04-2014 08:33 PM
dnarby
Volvo 240, 740 & 940
5
01-21-2014 10:02 PM
Falasi4
For Sale / Trade
2
01-24-2012 01:33 PM
irenass80
Volvo S80
2
07-24-2011 09:12 PM
WORF_Lx
Volvo S80
2
10-10-2006 09:52 PM


Thread Tools
Search this Thread
Quick Reply: 2000 S80 non- turbo, crazy idle???


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.