Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Another crank, no start (runs on ether)

  #1  
Old 08-04-2014, 11:18 PM
Junior Member
Thread Starter
Join Date: Aug 2014
Posts: 1
Question Another crank, no start (runs on ether)

Read past posts until i was cross eyed. Out of ideas. Need some outside input. 2001 S80 2.9 Non Turbo 93K

Short version:
Timing belt replaced at 79K
No Codes
Replaced Crankshaft Position sensor
Replaced Camshaft Position sensor
Have 54/55 psi Fuel pressure at the rail
Spark Plugs are wet after cranking
Replaced spark plugs
Spark is present
Replaced ECU
Runs momentarily on ether.

Long Version:
Neighbor purchase 01 S80 2.9 Non Turbo sedan about 6 weeks ago. Car ran fine. Last week the Low coolant light came on. Did not overheat. Started car, pulled from the street into the driveway and turned it off. Added just a bit over a quart of water to the overflow/expansion tank. restarted car, verified that the light was now off and shut it down. Next day, it wouldn't start. No codes present. Also scanner was unable to pull any live data from the ecu. Checked fuses. Swapped Fuel pump relay. Performed a reset i had read about. key in position 2 and reconnected the battery. no change... cranks, but won't start. BUT now it gave me a code for the crankshaft position sensor. replaced that and still no start. CPS code will not clear. Pulled the ecu and found a couple of burnt components. Replaced the ecu, (I know it will have to be programmed, but from what i have read, it should start and run momentarily before shutting down.) CPS code now gone, and i am able to read live data from the ecu. Still won't throw a code during/after cranking. Checked fuel pressure, 54/55 psi. Verified spark on one cylinder. Replaced the Cam Position sensor due to forum reading. Plugs were Volvo plugs and looked to be in bad shape (black soot and hardly any gap due to deposit build up. Replaced plugs. Give it a shot of starting fluid (ether) and it will run for a few seconds. Have Vidas and dice ordered, delivery later this week, but in the meantime, any other suggestions or ideas that i can pursue relating to this problem. Thanks in advance.

Vandy
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fulchiero
Volvo 240, 740 & 940
4
11-27-2011 07:57 PM
Lavid2002
Volvo S40
6
05-26-2011 06:00 AM
Lavid2002
Volvo S40
0
03-01-2011 06:20 PM
datderboy216
Volvo S40
1
05-22-2010 06:38 PM
rpsail7cs
Volvo XC70
10
09-25-2009 09:12 AM


Thread Tools
Search this Thread
Quick Reply: Another crank, no start (runs on ether)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.