Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Brake Failure, service transmission, srs airbag

  #1  
Old 02-22-2013, 05:51 PM
Junior Member
Thread Starter
Join Date: Feb 2013
Posts: 4
Default Brake Failure, service transmission, srs airbag

So I've been having some weird problems:

It started with the Brake Failure dashboard message, along with STC, ABS, and Brake lights; I would get this msg infrequently and I would disappear on restart. Then, out of the blue I got SRS service urgent and Service transmission soon messages and NO brake failure message; and I get trouble starting the car sometimes.

I let the car sit a few weeks and today I insert the key into position II and I see the following:
1) The SRS airbag urgent dashboard msg
2) after a second or two, it turns into the brake failure msg (along with the assorted lights) and the SRS airbag msg dissapears
3) The engine cranks, but doesn't manage to start


Next, I connected a cheap OBDII reader, insert the key to position II and I see the following:
1) Now, instead of the brake failure message, I just get the SRS urgent and Transmission soon messages <<<<What just happened here???? I connect the scanner and the dashboard messages change?!>>>

2) I turn the key and the engine starts
3) No check engine, but the srs and transmission messages remain
4) no brake failure message
5) i drove around for a few miles and it seemed fine, i got up to 40,50mph with no trouble, although i didn't try anything faster.


Somebody suggested that it may be the gas pump, so I released the pressure on the fuel rail and tried to start the car....it wouldn't start. Next, I disconnect and reconnect the battery and...it starts!

Right now, i am thinking it could be a few things:
- The abs module malfunctions and causes the computer to throw the SRS and transmission codes OR
- the Gas pump fails and doesn't let the car start OR
OR - the central computer is malfunctioning and affecting the other systems

Can anyone help? I am no car expert.

Thank you
Oscar

edit:
I drive a 2000 s80 with about 140k miles, no turbo.

Update:
I went through the procedure described here: http://www.matthewsvolvosite.com/for...hp?f=11&t=5827

I got these results:
'DTC set' for: ABS, SRS, TCM, ECM, CEM, DIM, CCM, PSM, REM, SWM, UEM
'Ready' for: LSM and AUM
'Checking' for: DDM and PDM
 

Last edited by og610; 02-22-2013 at 06:21 PM.
  #2  
Old 02-22-2013, 09:49 PM
Senior Member
Join Date: Oct 2010
Posts: 5,021
Default

There are a lot of possibilities- without having the codes from those modules checked (a generic scanner likely won't be much help), guessing can get expensive.
 
  #3  
Old 02-23-2013, 12:57 PM
Junior Member
Thread Starter
Join Date: Feb 2013
Posts: 4
Default

Well, if you had to take a guess....what do you think it could be?
 
  #4  
Old 02-23-2013, 01:05 PM
Senior Member
Join Date: Oct 2010
Posts: 5,021
Default

I would guess you have more than one problem. A bad ABS control module can cause the transmission service message to come on, but not SRS.

Or you could have a bad CEM.

Battery voltage can be an issue.

Or you could have fault somewhere else in the CAN system (wiring, terminals, etc).

I would not guess the fuel pump, however.
 
  #5  
Old 02-23-2013, 01:13 PM
Junior Member
Thread Starter
Join Date: Feb 2013
Posts: 4
Default

Okay, thanks!

Battery voltage seems like easier and cheaper to check. I'll start there.

A few people have also suggested the ABS module...If I took it out, is there a way I can check if it is working properly?

Edit: Also, when I use the OBDII reader, I get codes P1633 and P1631. That leads me to believe it might be the abs mod.
 

Last edited by og610; 02-23-2013 at 01:16 PM.
  #6  
Old 02-23-2013, 04:38 PM
Senior Member
Join Date: Oct 2010
Posts: 5,021
Default

Nothing you can test on the ABS control module.

I'm not at work so I can't covert those generic codes to Volvo-specific ones, which may help get a better guess. But there are certainly codes stored in the other modules that a generic scan tool won't read that could be helpful.
 
  #7  
Old 03-05-2013, 12:08 AM
Junior Member
Thread Starter
Join Date: Feb 2013
Posts: 4
Default

for anybody wondering, I got my battery replaced. It seems that the low voltage was triggering false positives
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
pharunk
2001-2013 model year XC70
3
07-27-2014 06:11 PM
giannis-21
Volvo S40
0
08-10-2011 01:50 PM
Sparky4688
Volvo 850
23
09-26-2009 06:22 AM
aldeener
Volvo S80
6
07-08-2008 09:02 PM
OverTheTop
Volvo S80
3
09-29-2005 01:04 AM


Thread Tools
Search this Thread
Quick Reply: Brake Failure, service transmission, srs airbag


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.