Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

help needed fast!!

  #1  
Old 04-19-2008, 11:06 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default help needed fast!!

ok i drove my 99' to vermont on vacation.. i left today heading back to NC and before i left i topped it off with 87 octane.. when i say i topped it off i mean it was dribbling as i put the cap on. i headed out and all was fine untill i had about 3/4th of a tank left.. i started feeling a pulsing sensation as i came to inclines on the interstate.. i had the cruise ctrl on but it felt like it would if i was pulsing the gas pedal durring normal driving. at fist i thought it was wind gusts but i took it off cruise to see if that was the problem.. it still did it.. then i tried getting on the gas a bit and as soon as i did the engine cut out completely... if i let off the gas it would go back to idling and if i was gentle i could keep it at about 70 mph... then if i can to an incline it would start jerking realy bad.. so then in order to make it up hills i had to get speed from going down a hill and then kinda coast up the next one.. at this point im thinking its one of the following..

bad gas (full of water)
fuel pump going out
clogged fuel filter/s
vaccume leake

well i pulled it into the next gas station a filled it up again...

when i got back on the road it was fine.. then when it got to about 3/4 of a tank it started doing it again and even stalled once on a hill. filled it up again and it was fine again.. im at a hotel now and got here before getting to 3/4 of a tank again but id bet every dime i got that it will do it again at 3/4 of a tank.. im confident it will be fine the rest of the way as long as i keep putting gas in at 3/4 of a tank...im not getting any messages or lights at.. im 99.9% sure its fuel related.. im not sure if its bad gas or fuel pump but pretty sure its one of the two.. the reason im thinking fuel pump is because it hasnt felt like i have been getting 100% power out of it lately (see me other post about that) and also it doesnt seem to be rpm related at all.. ONLY power related meaning it only does it when i need power... like its starving for gas.. but then i think it might be bad gas for one because the gas station i went to is known for putting water in the gas... also i know you can get water in your gas if you got it when the gas station tanks were near empty and then also because its so intermittent.... like it will do it and then not do it as bad but then it will just cut the engine completey out like if it would if it took a big gulp of water.. so i cant tell if it works ok after filling because iam stirring up the gas and water to something usefull and then it starts again after it all settles or ifthe tank being full gets enough fuel pressure to make it run ok.. im baffled and am wondering if anyone has seen anyone else report a similar issue that could indeed tell me it was a the fule pump for sure.. thanks in advance!

OH ALSO.... it does it with A/C on OR off, i just had the turbo control valve thing replaced also... and it happends at power requirements MUCH less than when using turbo..it happens even when just breathing on the gas pedal durring inclines. theres no way its turbo related unless i have two problems..
 
  #2  
Old 04-20-2008, 06:22 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: help needed fast!!

Try getting some dry gas and putting it in.
How long is it taking you to hit 3/4?
Maybe someting is blocking the pickup in the tank and you are actually low on fuel?
 
  #3  
Old 04-20-2008, 08:12 AM
Senior Member
Join Date: Mar 2008
Posts: 368
Default RE: help needed fast!!

First, topping off, bad. You could have gotten some dirt down into the tank from doing that (not guaranteed) and it could be clogging your filter.

It also could be completely a coincedence.
 
  #4  
Old 04-20-2008, 03:25 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

ok i made it home.. but indeed i needed to keep it at more than 3/4 of a tank the whole time.. the last time i filled her up i floored it leaving the gas station and it cut out so that tells me that even though it works ok durring normal operation with a full tank that it is still starving for gas.. i am 100% convinced that it is a starvation problem and is directly associatedwith the amount of fuel in the tank (the more fuel the more pressure in the fuel lines.. im pretty sure its not a clogged filter cause they were just changed but i guess its possible.. i think im going to go out now and see how hard the sending unit/fuel pump is to get to..
 
  #5  
Old 04-20-2008, 04:54 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

hey tech im trying to get those side things out of the back seat.. i can see the upper tab i have to push and i can see where it fits in the bottom but i cant get the bottom to release? also is there two pumps or one?
 
  #6  
Old 04-20-2008, 05:22 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

ok i got the seats figured out what a pain the first time... i got to the fuel pump and had my fiance turn the ignition on.. it powers on for about 1.5 sec and stopps and when i turn the car on the pump is working.. what do ya guess is the next step.. do i have to remove the sending unit to check the other pump? i read on here there is also a line going between the two pumps or between something cause its a split tank.. im guessing i have to pull it out and look inside..
 
  #7  
Old 04-20-2008, 05:52 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

ok anyone know how to get the fuel pump out? i have the lines removed.. it looks like it does on any other car except the ring is plastic and looks maybe to be threaded.. im guessing i need a special spanner wrench or i need to make one? if you havnt noticed i will keep on working but im hoping to get advice before i break it lol
 
  #8  
Old 04-20-2008, 05:59 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: help needed fast!!

You need to remove the ring to get the pump out.
 
  #9  
Old 04-20-2008, 06:01 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

yea thats what im trying to figure out.. is it a screw off? do i need a special wrench? thanks tech
 
  #10  
Old 04-20-2008, 06:40 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: help needed fast!!

It unscrews.
Usually you need a special tool but some have used screwdrivers and gotten it off.
 
  #11  
Old 04-20-2008, 07:08 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

cool i been workin at it like that.. its on there pretty good
 
  #12  
Old 04-20-2008, 07:11 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: help needed fast!!

They usually are.
 
  #13  
Old 04-20-2008, 07:40 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

well i just changed the main filter under the car and im not 100% sure if that fixed it or if its coincidence but this thing has more power than it has since i bought it and i cant get it to hesitate at all.. the filter was last changed in 05 according to the book for the 105000.. its at 123000 right now.. maybe something at that gas station clogged it up.. all i can say is wow.. i will keep the seats out and pull the sending unit out if i CAN and look at it anyway..
 
  #14  
Old 04-20-2008, 07:45 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: help needed fast!!

Good luck I might say clogged filter.
Did the old one look really old?
 
  #15  
Old 04-20-2008, 08:19 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

i couldnt see anything obvious after i took it out but anyway i got it to cut out again.. its still running twice as good as it used to with the filter but it still cuts out if i realy get on it.. so i will be taking the sending unit out next.. hope fully it will be something stupid and easy and cheap lol yea right.
 
  #16  
Old 04-20-2008, 08:57 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

ok im screwed. i made a tool to do it and it friggin snapped off some teeth and i busted one of the plastic fuel hook ups.. so now i cant drive it anywhere and i still cant get that dang ring off. i can get the pump within a couple days but i dunno bout the ring.. im thinking about just busting the ring off and replacing it but i dunno if id end up breaking something else in the process. my other vehicle ( a truck is loaded with gravel so That will be fun to drive around.. lol
 
  #17  
Old 04-20-2008, 09:11 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: help needed fast!!

Do you have 2 long screwdrivers?
If so lock one in the groove. Then the second one in a groove on the opposite site. Then angle and try to press each other and try to turn it.

Also another tip. You are opening up a can of worms here.
You also have to remove the sending unit on the drivers side and fish the wiring out through the tank.
When you do that tie a piece of small rope in the loop on the drivers side. This will help you feed the wires and hose back to the drivers side.
Also be sure to order 2 o-rings to replace the ones in there now. Or it might leak when you are done.
 
  #18  
Old 04-20-2008, 09:30 PM
Senior Member
Thread Starter
Join Date: Feb 2008
Posts: 129
Default RE: help needed fast!!

thanks good tips!
 
  #19  
Old 04-20-2008, 09:32 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: help needed fast!!

Let me know how it goes.
 
  #20  
Old 04-20-2008, 10:20 PM
Senior Member
Join Date: Jan 2008
Location: Tampa, FL
Posts: 879
Default RE: help needed fast!!

If you dont mind me asking, which gas station did you fill up at? Is it a major national brand? if so let us know who to avoid!
 

Thread Tools
Search this Thread
Quick Reply: help needed fast!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.