Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Low Beam electrical problem

  #1  
Old 05-22-2006, 11:48 AM
Thread Starter
Join Date: May 2006
Posts: 4
Default Low Beam electrical problem

Does anyone know how to solve this?

Im having electircal problems with the low beam circuitry.. I had my low beams converted to HID then after a few days, the beams wouldn't turn on anymore.. I checked all fuses and non are busted. I tried placing back the regular halogen bulbs and it didn't lit on. Meaning to say there is something wrong with the electircal line and not the fuses. By any chance, is there a specific relay related to this? thanks hope to get anybody's reply soon.
 
  #2  
Old 05-23-2006, 12:50 AM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Low Beam electrical problem

Check the CEM under the Dash on the Drivers side. You will have to unlatch it and fold it down. There is a funny looking skinny long relay type thing. That controls the Low beams. Look for Melted marks in the plastic.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Volvo_Neps
1998-2000 model year V70
3
10-07-2013 10:28 PM
Volvoguy505
Volvo 240, 740 & 940
4
09-11-2010 05:53 PM
Jimbo_Jones
Volvo S60 & V60
13
12-11-2009 01:41 PM
volvo40_2k
Volvo V40
0
07-28-2009 09:18 PM
Osiris1975
Volvo S60 & V60
4
10-06-2007 07:30 AM


Thread Tools
Search this Thread
Quick Reply: Low Beam electrical problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.