Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

My car litterally had a mental break down...

  #1  
Old 09-09-2009, 09:45 AM
elmo_allen's Avatar
Senior Member
Thread Starter
Join Date: Aug 2008
Location: Indianapolis, IN
Posts: 197
Default My car litterally had a mental break down...

Fair warning this is a long post.

Over the past month I have been dealing with an issue that has even the top Mechanics at the dealership stumped.

I was driving home from my BFs house and all of the sudden my car loses power and the gauges flat line. So I stop the car put it into park turn it off and then turned it back on. When I go to put it into drive, on the dash it is reading that it was in Neutral, and the car lost some of the steering capability. So I barely get it stopped and I turn the car off and then turned it back on. This time it was lunging forward and it sounded really bad, kinda like I blew a muffler, but I didn't. So I go and park it, turned it off again and call my mom to come get me. While waiting I turn it back on and was trying reverse, it was fine going in reverse, I try drive, 3, 2, and 1, and I get the horrible noise and lunging. So I park it ASAP and turned it off. I tried the key to see if there were any errors and I was getting everything from break failure to transmission service required. Also I was hearing a clicking noise from the gear box. Once my mom got there I decided to have AAA come and tow me to my house.

The next day I go out and my battery is dead. I mean no lights on anywhere, no horn, nothing. So I get AAA to come out again and jump me so that I can take it to a dealer. Luckly I made it and the tow driver was nice enough to follow me up there just in case I had a problem. So once I get there I get a new battery and I had the car rebooted. Everything was fine but they said that I needed to replace my ABS control Mod, which I knew ever since I had the car. So I paid my bill and drove it around and everything was fine... until the next day.

I am coming home from doing some running around, exactly around 1PM (this become important later) and I notice that my SRS airbag warning light was on. So I pull off, turn the car off and call my dad to see what he thought. He just said bring it home and we will take a look. So I go to start the car and it would not start. It took me three times to get it started. Once I did I rushed home ASAP but it was starting to lose steering and breaking, but nothing was wrong with the transmission. So I get it home and I park it. I remembered a while back about asking everyone about getting my ABS mod rebuild so I thought that this would be a good time to do it. So I took it out per the instructions given and sent it out to be rebuilt. The guy who did it, (Victor Rocha) saw that I had 3 distinctive cracks on my circuit board, so he replaced that and tested it and sent it back to me. During that week I did not start the car because I was afraid that I would mess something up. I also noticed that the battery was still holding up until the day before I got the mod back. The battery died again. So once I got the part I put it back in per the instructions and tried to start it. Nothing... So we thought that we would charge the battery and see if that would work. We charged it for two days and it still would not start. So I had AAA come out again and tow me up to the dealer and they did a full check and rebooted the car again and it worked... This was this past Friday... Then on Saturtay, not even 24 hours after I got my car back this happens...

I am going and doing some running around again and I stop at Wallie World (Wal-Mart) to pick up some things and right before I went there the gauges dropped and I got a break failure warning nothing else. So I turn it off again and turn it back on. It was fine, no errors, nothing was wrong, so once I get there I go and park and do my normal routine and lock the doors etc... when I come out at 1PM it would not start. It would start and then die. It did this twice before it just would not start at all. Then there was clicking noises from the gear box again. So I called my dad and my mom to see what they thought and I decided once again to call AAA and have them tow me. (I was not having a good day that day either. While I was stranded my cell phone died and everyone and their brother was asking if I was OK do I need a lift etc... Needless to say it was annoying.) So when AAA came I took it to the dealer again and this time they are driving it around and even the Service Manager (who is also my neighbor's live in BF) is getting in on this. He took it home with him. ( I jokingly said that he should take a tow truck with him when he does.) So it has been across the street from me looking all sad and pathetic, torturing me because I want to drive it so bad it's frustrating.

So here we are today the second day that Volvo has had it and I have not heard anything yet. But they did said yesterday that the "brain" (I think it is called the ECM.) of the car is not communicating with the other mods. So does anyone know what could possibly be wrong.

I am trying to be positive and having a since of humor about this because on the inside I am pissed beyond belief. So I've been making jokes about this situation saying, "My car is having it's mid life crisis, and it went mentally insane." and if people ask me where it is I say "Oh it is in the loony bin right now getting therapy. I think it over heard me talking about getting a Camaro SS for a second car. That is when this all happened. I think we also need couples therapy."

In all seriousness I have not given up on this car yet, and I don't plan too, but if it truly is the transmission, I don't know what I'm going to do, because I don't have that kind of money to fix that. Unfortunately...

Please and thanks for helping me figure it out!
 

Last edited by elmo_allen; 09-09-2009 at 09:59 AM.
  #2  
Old 09-09-2009, 08:57 PM
Senior Member
Join Date: Dec 2006
Location:
Posts: 311
Default

I picked ECM before you said it... but they better break out the multimeter and trace some wiring as well. Don't pay for a brand new if you can get it rebuilt... that's over a grand for a new one...
 
  #3  
Old 09-10-2009, 07:30 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Did they try a new ABS module in it to see if that fixes it yet?
 
  #4  
Old 09-14-2009, 12:49 AM
elmo_allen's Avatar
Senior Member
Thread Starter
Join Date: Aug 2008
Location: Indianapolis, IN
Posts: 197
Default

They made sure the ABS mod worked when I got it back the second time, and when I had trouble again, they reset the system and checked all of the Mods and found that the mods are not communicating with each other. So they test drove it until the car did it again, they determined that it was the ECM. They came to that conclusion because of all of the symptoms it was having, and something was still shutting the system down. They even checked and rechecked for codes and see if the battery and alternator worked and everything checked out fine and then the system would shut down. So they were back to square one trying to figure it out.

I asked if I could get it rebuilt and it took them 3 hours to get back to me saying that they did not know of any company, any more, who does rebuilds for my year and model. They said that the company that they used went out of business because of the recession. They did not give me the name of the company though.

So this past Friday I broke down and had them put a new one in. They are giving me a discount though because of all of the trouble I have gone through this past month. So now they are going to drive it and see if that fixed it and if that does not work... Then there is little hope for it unless it is another mod going out, but with replacing two of the most important mods in the car it "SHOULD" work. I am really hoping that putting in a new one fixes it. If it is not that what else could it be?

Oh and I will defiantly make sure that all of the wires are checked. I don't want to take it back there for the same problem again, and they know that. They, the dealership, feel really bad about it because they guarantee that the work is done right the first time, and they honestly missed this and they know my situation with this car. They almost don't want me to come back there. They are joking of course because of how many times I have been in for this, that, or the other, but hey I told them when I got this car that they will be seeing me a lot. I just did not know it was going to be this frequent. LOL
 

Last edited by elmo_allen; 09-14-2009 at 01:00 AM.
  #5  
Old 09-14-2009, 08:34 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

They just checked the ABS module or put another one in?
 
  #6  
Old 09-15-2009, 11:58 AM
elmo_allen's Avatar
Senior Member
Thread Starter
Join Date: Aug 2008
Location: Indianapolis, IN
Posts: 197
Default

I had the ABS mod rebuilt and they checked it and it checked out fine. No problems.
 

Last edited by elmo_allen; 09-15-2009 at 12:02 PM.
  #7  
Old 09-15-2009, 06:31 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Oh ok wanted to make sure.
 
  #8  
Old 09-15-2009, 06:38 PM
elmo_allen's Avatar
Senior Member
Thread Starter
Join Date: Aug 2008
Location: Indianapolis, IN
Posts: 197
Default

No problem! Thanks for helping me. It may not seem like it but you guys did. I'll tell you all what happens.
 
  #9  
Old 09-15-2009, 06:45 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Waiting with fingers crossed to hear back from you.
 
  #10  
Old 09-22-2009, 11:18 AM
elmo_allen's Avatar
Senior Member
Thread Starter
Join Date: Aug 2008
Location: Indianapolis, IN
Posts: 197
Talking

Well they replaced the ECM and everything is working better than when I bought the car. I had a speaker problem, and now it is fixed and sounding better than ever. I don't have any error lights, I have ABS breaks, and the best thing of all is that all of the modules are communicating again!!! WoOT!!! However it did cost an arm, a leg, and my left ear to fix it but hey it was well worth it. I have my Damian back!!! LOL Thanks for helping me figure this out.
 
  #11  
Old 09-22-2009, 07:33 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default

Glad all is good now!
 
  #12  
Old 09-22-2009, 07:38 PM
Senior Member
Join Date: Dec 2006
Location:
Posts: 311
Default

Those pesky computers...
 
  #13  
Old 09-23-2009, 08:02 AM
elmo_allen's Avatar
Senior Member
Thread Starter
Join Date: Aug 2008
Location: Indianapolis, IN
Posts: 197
Default

Indeed. Thanks again!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
crosby1
Volvo S40
1
03-09-2011 04:28 PM
hadley
General Volvo Chat
0
01-28-2011 10:13 AM
Volvorator
Volvo 850
8
12-30-2010 11:43 PM
backbone11
Volvo 850
2
12-04-2008 08:25 AM
suprattracer84
Volvo 850
21
11-06-2008 10:24 PM


Thread Tools
Search this Thread
Quick Reply: My car litterally had a mental break down...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.