Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

s80 d5 se lux 2006 please help

  #1  
Old 02-18-2013, 02:40 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 4
Default s80 d5 se lux 2006 please help

Hi fellow volvo techies, i desperately need help on this, i run the car and everything seems pretty fine till the car reaches running temperature, then it starts to get pretty erratic, ie ... revs tart to run high for a second or 2 inbetween gear changes, to about 3500 revs at low speed, if im driving urban say for about 10 miles or so, when i stop the car you can smell that the engine is really hot , but temp gauge is right in the middle, so when i turn the engine off the fan will kick in..... but if i turn the ignition on without starting the engine, the fan will stop... if i leave the car turned off the fan will run for about 4 to 5 mins, what puzzles me is why the fan turns off when i turn the ignition on, im thinking when the car is running the fan is not working, thats why its heating up and getting erratic, hope i can get some good feedback from you guys on this forum... many thanks in advance.....
 
  #2  
Old 02-18-2013, 03:56 PM
akabond's Avatar
Senior Member
Join Date: Nov 2010
Location: Texas
Posts: 434
Default

an european S80 eh??? ..well it looks like some electrical problem. do you get any error message displayed?? maybe you might have to replace the entire fan or inspect the fan module
 

Last edited by akabond; 02-18-2013 at 03:59 PM.
  #3  
Old 02-18-2013, 04:04 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 4
Default

yes uk , ofton get engine service required, but when i turn off engine and restart, error message clears, ???
 
  #4  
Old 02-18-2013, 09:19 PM
akabond's Avatar
Senior Member
Join Date: Nov 2010
Location: Texas
Posts: 434
Default

well in anycase get that error code checked with a scanner..do it when you see the message
 
  #5  
Old 02-18-2013, 11:40 PM
Junior Member
Thread Starter
Join Date: Mar 2012
Posts: 4
Default

the only time i get that mesage is when the car is cold and i accelerate quickly then get error engine service required, the car goes in limp mode, i stop turn of engine , restart car error clears and car is out of limp mode , any more suggestions please.
 
  #6  
Old 02-19-2013, 09:03 AM
akabond's Avatar
Senior Member
Join Date: Nov 2010
Location: Texas
Posts: 434
Default

well like i said you have to get that code when there is that message. That way you can identify the problem. Either keep a scanner in hand or as soon as you get that message go to a mechanic and get it checked
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MNWILD
Volvo 240, 740 & 940
18
04-01-2018 09:11 PM
nasus
Volvo S60 & V60
1
07-02-2012 06:57 PM
gravedigger
For Sale / Trade
0
07-17-2010 07:30 AM
baer77
Volvo S40
10
07-05-2010 11:24 AM
robretpd
Volvo S80
2
02-21-2006 12:02 PM


Thread Tools
Search this Thread
Quick Reply: s80 d5 se lux 2006 please help


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.