Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

S80 T6 won't start since cold weather arrived

  #1  
Old 11-28-2012, 02:52 PM
Junior Member
Thread Starter
Join Date: May 2012
Posts: 18
Default S80 T6 won't start since cold weather arrived

I have an 04' S80 T6 that I have recently replaced the throttle body, mass air sensor, fuel pressure regulator and crankshaft position sensor on. Most recently the throttle body was replaced and the car ran fine until the temerature in my area went from 55 degrees to about 30 degress in one day. The car has not started since the weather turned cold-starting fluid does nothing. Any help would be greatly appreciated. This car ran trouble free for the first 2ooK, however since turning 200K it has become a nightmare, and I no longer trust it to go any distance.

Thanks
 
  #2  
Old 11-28-2012, 09:31 PM
Junior Member
Join Date: Aug 2012
Location: Traverse City, MI
Posts: 20
Default

If starting fluid does nothing, I'd say it's a no-spark issue. May want to re-check the crank position sensors if it just cranks and doesn't start, as if something isn't right with those the car will not provide ignition. I've had no experience with these on mine, but I did have a Northstar cadillac that had CPS's go bad and this sounds an awful lot like that.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jpm2346
Volvo 850
12
12-23-2016 02:35 PM
Ecochic88
Volvo 240, 740 & 940
4
09-08-2011 10:53 PM
healthnt
Volvo 850
2
07-27-2010 11:05 PM
MI_Marcus
Volvo 850
2
01-07-2010 10:39 PM
arttu
Volvo S70
1
02-15-2007 10:16 PM


Thread Tools
Search this Thread
Quick Reply: S80 T6 won't start since cold weather arrived


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.