Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

sensors lots of trouble

  #1  
Old 09-29-2010, 03:21 AM
Junior Member
Thread Starter
Join Date: Jul 2010
Posts: 4
Default sensors lots of trouble

my trouble started with cel just cleared code and it would run fine even with lite on for monthes...then it would run rough 3 cyls shut down ,cleared codes and it would run fine for weeks, then same scanner said it was bank 2 sensor 2, changed it still not working good after cel lite comes on again scan tool says bank 2 sensor 1 ...changed it and worked good for a day and cel on again it wants sensor bank 2 sensor 2 changed it again after a few weeks and still throwing codes now bank 1 sensor 2...iam wondering if the computer is gone nuts and can i erase it and ... i have since bought my own scanner and keep it in the car to make sure i can get home ... any help on this is certainly appreciated
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lukaspanic
Volvo S40
8
06-07-2015 07:19 PM
samadkins29
Volvo S70
266
07-02-2007 04:17 PM
90_740turbo
Volvo 240, 740 & 940
5
05-23-2006 12:17 AM
ludeless
Volvo 850
14
03-14-2006 11:27 PM
dalton
Volvo S80
1
01-13-2006 02:31 PM


Thread Tools
Search this Thread
Quick Reply: sensors lots of trouble


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.