Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Weird Power Loss

  #1  
Old 03-12-2008, 11:22 PM
Member
Thread Starter
Join Date: Sep 2007
Location:
Posts: 81
Default Weird Power Loss

1999 S80 T6

I read somewhere in this forum but couldn't find the thread on this. Here's the situation:

When I am accelerating steadily, my car loses power rythemically. For example, at around 2000 RPM while accelerating, the RPM needle suddenly drops to 1700 RPM for a fraction of second and goes to normal (2000 RPM). This happens so quick and abrupt that when you are watching the road, you can feel the power loss, and before you turn your eyes to the dashboard, its back at normal acccerelation RPM. It happens as fast as you can snap your fingers. And... this happens at equal intervals, almost once every 1.5seconds or something, but at exact intervals. Please refer to the image for the example cycle of power loss.

I have no idea why this happens. But, one fine day, it suddenly stopped doing that. There are3 things I did to the car on that fine day:

1. Changed the engine oil (at 3000 miles and I use Castrol Synthetic Blend 5W-30)
2. Replaced the Break Pedal Position Sensor
3. Used Techron fuel system cleaner while filling up the gas

Again, I have no idea which of these 3 factors contributed to a little peace of mind while accelerating (the weird transmission shudder still exists though).

Questions:

Why is this power loss happening? Where is the problem? I am guessing, the engine oil change affected the situation and provided a temporary remedy. Is it true?

Thanks guys.

[IMG]local://upfiles/12401/582EE9BDC6054EFAA048097ED27CD253.jpg[/IMG]
 
  #2  
Old 03-13-2008, 06:10 PM
Join Date: Dec 2007
Posts: 53
Default RE: Weird Power Loss

my 2000 2.9 was doing the same thing, replaced the brake pedal sensor, all is well now.
 
  #3  
Old 03-16-2008, 12:53 AM
Member
Thread Starter
Join Date: Sep 2007
Location:
Posts: 81
Default RE: Weird Power Loss

ORIGINAL: rotgut

my 2000 2.9 was doing the same thing, replaced the brake pedal sensor, all is well now.
Hmmm... interesting. I wonder what the faulty brake pedal sensor is doing to trigger this phenomenon.

Thanks, rotgut for the input.
 
  #4  
Old 03-16-2008, 11:22 AM
Join Date: Dec 2007
Posts: 53
Default RE: Weird Power Loss

I dont really know, odd isnt it, my volvo dealer that I go to happens to have two seasoned techs that are personal friends of mine, I took the car to them and they went right to the brake sensor, anyway, glad you sorted your out, who would have thought.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Wesley brown
Volvo 260, 760 & 960
5
10-07-2014 10:12 AM
swiftjustice44
Off Topic
8
10-25-2012 06:32 AM
S70_5sp
Volvo S70
15
07-25-2012 08:59 AM
WHYAYEGTI
Volvo S60 & V60
1
04-17-2005 08:00 PM
larwood
New Members Area
0
07-24-2004 12:32 AM


Thread Tools
Search this Thread
Quick Reply: Weird Power Loss


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.