Volvo S90 & V90 Returning for 2017, This sleek full sized sedan mixes luxury with a sporty look.

1998 Volvo S90, cranks, but does not start

  #1  
Old 02-11-2019, 07:36 AM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 3
Default 1998 Volvo S90, cranks, but does not start

Hi all, so i am new here and this is my first post! About my self, i am tech savvy and very mechanical, so nothing really scares me. I do all my own work and troubleshooting but finally am stumped and would like some input before i just start replacing parts. I am not the best with electrical but learn fast.

So about my car, its a 98 s90 with 245,000 miles, i would have owned it since 80k. At this age though now my car does not like sitting and needs to be driven as if it sits too long things start to go wrong. I won't get rid of it cause its my first car and i love it and do enjoy tinkering on it.

My current issue and all I am seeing:
car cranks strong, and thats it! All my dash lights electronics lights etc all work normal still. However, i also noticed that the transmission mode lights of sport and economy are both lit. I also am unable to connect to the ecu, my obd2 scanner indicates linking error. Although it used to connect no problem and connects to other vehicles fine.

What i have done to date:
So how this started was, i actually needed rear brakes, and since i have more than one vehicle it i left this one on the jack stands while the pads were being shipped. Needless to say it was running driving when i parked it, and i waited a week with the rear in the air before getting it back together and rolling. At first start up it was cranking alot and spitting and sputtering to get fired, once fired it idled poorly, but cleared up, so i assumed this to be a bit of leak down maybe in the cylinders and just not running etc but it cleared up and was idling like always i shut it down and in the afternoon went to take it for a spin and same hard start up. Spitting and sputtering. But ran and cleared up. I took for a spin and it actually did the same sputtering behavior on the drive, what was odd was after parking and let idle for a bit, it would just shut down like someone turned the key off and it would do this repeated. I checked codes, and i had an 02 sensor (that was existing exhaust leak) but 2 new codes for ect and idle air control. I cleared them, thinking it was a fluke of the rough start up. Well the gauge was acting funny and the fan would run after i shut the car down, so i replaced the thermostat and ect and thats seems to be remedy that issue. So finally, i parked it then came out to fire it up and she cranks, and nothing, no sign of wanting to start.
Since that i now have, as i said the tranny lights on and the obd2 wont connect and i have do have fuel in the rail and at the Schrader but i have not pressure test. But no spark that i can tell.
After the ordeal of not starting relays were clicking away like mad. The fuel pump etc. So i made a mission to go and clean every ground in the engine bay. I even took the intake off and remedied those by the engine mount and that seems to have solved my problem of relays clicking. The cel would flash the same sequence of the relay chattering and unfortunately eventually blew probably cause i let it.happen to much in troubleshooting,Cause it no longer lights. So all grounds in engine bay are all set and tested with my power probe. But now i am back to no spark, i think i have fuel but would like to test relay etc. And the obd2 not connecting and the transmission lights both on.

Anyone have any thoughts where to start or check? Or what to test? Maybe relays or the ecm? Im at loss with the computer operated troubleshooting.

Appreciate in advance, any suggestions or what and how to test some of the electrical components!
Thanks all!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
harvisethi
2001-2013 model year XC70
1
01-14-2018 10:32 AM
Mick McM
Volvo V50
2
12-19-2016 09:38 AM
nightmarevolvo
Volvo 240, 740 & 940
18
08-11-2011 07:00 PM
mracr
Volvo S80
0
02-14-2007 12:53 PM


Thread Tools
Search this Thread
Quick Reply: 1998 Volvo S90, cranks, but does not start


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.