Volvo XC70 This wagon/SUV crossover offers the capabilities of an SUV without SUV size.

ECT/Thermostat issue?

  #1  
Old 04-19-2012, 03:51 PM
Junior Member
Thread Starter
Join Date: Apr 2008
Posts: 21
Default ECT/Thermostat issue?

Good day all,
Yesterday while driving to work the temp gauge progressively went from its usual midway point to just below red in a matter of less than 5 minutes. No dash lights came on and as soon as I turned on the heater/defroster, the temp came down a couple of ticks. On my way home, I ran the defroster full blast from the beginning of my drive for about 15 minutes and the temp gauge stayed in its normal midway point. As soon as I turned off the defroster, the temp gauge climbed to the red in less than 1 minute. The car is now parked until I figure this out. Any thoughts immediately come to mind? The presumed overheating was taking place on a 55 degree day at highway speeds. I'm wondering if this is merely a sensor problem or something greater. I already have a new Walher 87 degree thermostat in hand and am probably going to replace the ECT sensor while I'm at it, but if anyone thinks this is definitely something else I would be most grateful for the input.
Thanks!
 
  #2  
Old 04-22-2012, 06:55 PM
Junior Member
Thread Starter
Join Date: Apr 2008
Posts: 21
Default

I could really, really use some input on this issue...even if its just reassuring me that the thermostat and/or ECT sensor are most likely the issue. If that is so, is there a way to get the thermostat off without taking the fuel system apart?
Thanks
 
  #3  
Old 04-26-2012, 04:06 AM
Senior Member
Join Date: Nov 2011
Location: Chesapeake, VA.
Posts: 512
Default

Remove the thermostat and test with thermometer & pan of water boiling on stove. Use a meat thermometer.
 
  #4  
Old 04-26-2012, 12:05 PM
Junior Member
Thread Starter
Join Date: Apr 2008
Posts: 21
Default

Thank you for the heads up...before doing so, do you know of a way to get at the thermostat without taking apart the fuel system which blocks access to the rear T40 bolt?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
91shelby
Volvo 850
2
02-15-2013 03:22 PM
bikeboy1
Volvo XC70
0
11-26-2010 07:52 PM
jstarman
General Volvo Chat
10
11-09-2010 06:32 PM
mooses9
Volvo 240, 740 & 940
13
03-04-2010 01:23 PM


Thread Tools
Search this Thread
Quick Reply: ECT/Thermostat issue?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.