Won't Start after being on gentle slope - Volvo Forums - Volvo Enthusiasts Forum

Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo XC70
Reload this Page >

Won't Start after being on gentle slope

Volvo XC70 This wagon/SUV crossover offers the capabilities of an SUV without SUV size.

Won't Start after being on gentle slope

Reply

 
 
 
  #1  
Old 05-14-2018, 11:17 AM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 2
Default Won't Start after being on gentle slope

I have an 04 XC70 that has an odd issue. After parking on a quite gentle slope, nose downhill, it won't fire. It cranks just fine, however. It also has about 3/4 of a tank of gas, and had only been sitting there for about an hour or so. It also did the same thing after I had had it jacked up on the front passenger side (checking on a grinding noise, I need a new right side CV axle) on my otherwise flat garage floor. Again, nearly a full tank. Each time if I let it settle back to level for an hour or so (off the jack in the latter case, let it roll to a flat spot in my driveway in the former) it will start again without issue.

Any ideas on root causes? I'd hate to have this happen when I am out and about and need it to start right away.
 
Reply With Quote
  #2  
Old 05-14-2018, 01:39 PM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 2
Default

After browsing around some more other people seem to be pointing to the fuel pump being shot. Any other thoughts before I pick one up?
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PeterN
Volvo 240, 740 & 940
3
09-13-2014 11:41 AM
mountainredneck
Volvo 240, 740 & 940
6
04-30-2012 07:06 PM
vipul_vips
Volvo 240, 740 & 940
2
10-27-2008 05:17 PM
velovolvo
Volvo S70
1
05-01-2008 05:49 PM
GMad
New Members Area
7
04-16-2008 03:26 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory