Go Back   Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S60
Sign in using an external account
Register Forgot Password?
Search

Welcome to Volvo Forums!
Welcome to Volvo Forums,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Volvo Forums today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-27-2007, 10:25 PM
 
Join Date: Aug 2007
Posts: 1
Default 2002 S60 INSTRUMENT CLUSTER PROBLEM

I have a problem, I have a 2002 S60 approx 90k miles.. My complete cluster is out (no tach, speedo, odometer, or even gauges).. Any ideas? Checked fuses in car and under hood, nothing popped. Disconnected and reconnected battery, no change.. Called Volvo dealer, $200+ to diagnose... Anyone ever have a similar problem? Car starts, runs perfect. Thanks
Reply With Quote
  #2  
Old 08-28-2007, 03:14 PM
 
Join Date: Aug 2007
Location:
Posts: 331
Default RE: 2002 S60 INSTRUMENT CLUSTER PROBLEM

possibly the wiring to it has been disconnected somehow. Most gauge clusters dont operate of one wire or light. so the problem exists where everything is going to it. I know there are some fuses under the dash in the drivers side, but also some fuses are in the engine bay. not sure if that helps but try to find the wires and see where they go. maybe something accidentally vibrated loose.
Reply With Quote
  #3  
Old 08-01-2012, 10:39 AM
Junior Member
 
Join Date: Aug 2012
Posts: 1
Default

had the same problem had to have new instrument cluster panel i bought 3 on ebay
did not work you need to make sure that the numbers on the paper label on top match exact or it will not work drove to my local scrappy picked one up pluged it in and it worked still got a spare one here numbers are vcc p/no 9499669 s/no 14615 yzk p/no 69294-590t
Reply With Quote
  #4  
Old 09-12-2012, 12:28 PM
Senior Member
 
Join Date: Aug 2010
Location: Delaware
Posts: 234
Default

you have to replace the cluster, I just sent my here to be fixed use this link from this forum to get to the company that fixes dims of all types:

Where to Send Dim for Repair here is the direct link to the site its self...just sent mine off today Wed and will have it back Friday ready to install back in my car! Products for Volvo - Xemodex Inc. | Xemodex Inc.

I hope this helps you, it help me out and saved me a lot of money as Volvo wanted $1,200 for a new Dim(dash cluster)
Reply With Quote
Old 09-12-2012, 12:28 PM
 
 
 
Reply

Tags
02, 2002, cluster, dash, fuses, instrument, instument, panel, problem, problems, replacement, s60, volvo, wiring, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 06:56 PM.
© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company.
Secure Backup