Volvo S80 A performance sedan that offers top notch luxury, outstanding handling and so much more.

Intermittant Instrument Cluster Problem

  #1  
Old 07-06-2008, 12:04 PM
Thread Starter
Join Date: Jul 2008
Posts: 3
Default Intermittant Instrument Cluster Problem

Hi,

I have a 03 S80 D5 and just recently I've had an intermittant problem with the instrument cluster keep on resetting. If I start the car after a long wait, say overnight, everything is fine. But if I run the car for a while and stop then start it again I will sometimes see the problem. The problem is that the instrument cluster completely dies for about a second then comes back on for about 5 seconds then dies again and so on for about 10 - 15 minutes then it seems to be ok until I stop and start again. I think it is a reset issue as the odometer will go back to the mileage it was at when the problem started, I've recently done a 40 mile trip and only added 17 miles to the car, nice but not ideal from a service point of view. I do not get any error or warning messages at all. Any ideas or help greatly appreciated.

Nick
 
  #2  
Old 07-06-2008, 09:51 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Intermittant Instrument Cluster Problem

Is the ABS light on at all?
 
  #3  
Old 07-06-2008, 11:25 PM
Join Date: Oct 2007
Location:
Posts: 235
Default RE: Intermittant Instrument Cluster Problem

03 uses newer styleBCM (brake control module)unit instead of an ABS module (2001 and below)... Rarely dies.... Could be a network issue. Is there any other function of the car not working??? windows, seat, climate control, sunroof???
 
  #4  
Old 07-07-2008, 05:39 AM
Thread Starter
Join Date: Jul 2008
Posts: 3
Default RE: Intermittant Instrument Cluster Problem

Hi Tech,

Thanks for the quick response, No I have no warning or error lights or messages at all, not even when it's doing it's reset thing. Every thing seems normal except for the loss of instrumentation for the second or so.

Nick
 
  #5  
Old 07-07-2008, 05:46 AM
Thread Starter
Join Date: Jul 2008
Posts: 3
Default RE: Intermittant Instrument Cluster Problem

Hi mncx,

Thanks for the quick response, all functions seem to be working ok it's just the instrument cluster that's showing any problems, and only when all systems have warmed up. As I said in the original post there are no problems from a cold start, no matter how long I drive for. I only seem to get this issue from a warm start. Is there any way to test the network? or is that a trip to the dealer? I do have access at work to CAN monitoring devices but not the volvo command database.

Nick
 
  #6  
Old 07-07-2008, 06:02 PM
tech's Avatar
Administrator
Join Date: Sep 2004
Location: Orlando, Florida
Posts: 36,351
Default RE: Intermittant Instrument Cluster Problem

ORIGINAL: mncx

03 uses newer styleBCM (brake control module)unit instead of an ABS module (2001 and below)... Rarely dies.... Could be a network issue. Is there any other function of the car not working??? windows, seat, climate control, sunroof???
Just FYI I have done atleast 5 2003 or newer modules already this year. It still must have something to do with the Hot climate.
 
  #7  
Old 07-08-2008, 09:27 PM
Join Date: Oct 2007
Location:
Posts: 235
Default RE: Intermittant Instrument Cluster Problem

Taking it back to dealer to reload module??? I guess Canada is not that hot... so I guess I've only seen 1.... A lot of stuff happend up in Canada other area don't either...

ORIGINAL: tech

ORIGINAL: mncx

03 uses newer styleBCM (brake control module)unit instead of an ABS module (2001 and below)... Rarely dies.... Could be a network issue. Is there any other function of the car not working??? windows, seat, climate control, sunroof???
Just FYI I have done atleast 5 2003 or newer modules already this year. It still must have something to do with the Hot climate.
 
  #8  
Old 07-08-2008, 09:33 PM
Join Date: Oct 2007
Location:
Posts: 235
Default RE: Intermittant Instrument Cluster Problem

it's really hard to see what problem it is without knowing fault tracing code... The only other thing that u can do (BUT NOT RECOMMENDEDIF U DON'T HAVE ACCESS TO ERASING CODES FROM CAN NETWORK) is to unplug the module that is last in the line until the instrument cluster comes back up.. but can generate more codes that can lead to mis-diagnosis if u taking it into the dealer.

ORIGINAL: nicks

Hi mncx,

Thanks for the quick response, all functions seem to be working ok it's just the instrument cluster that's showing any problems, and only when all systems have warmed up. As I said in the original post there are no problems from a cold start, no matter how long I drive for. I only seem to get this issue from a warm start. Is there any way to test the network? or is that a trip to the dealer? I do have access at work to CAN monitoring devices but not the volvo command database.

Nick
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
airics
Volvo S60 & V60
3
09-12-2012 12:28 PM
chadman551
Volvo 850
8
03-04-2010 07:28 PM
chadman551
Volvo 850
2
12-19-2009 07:33 PM
danajess
General Volvo Chat
0
05-03-2009 03:37 PM


Thread Tools
Search this Thread
Quick Reply: Intermittant Instrument Cluster Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.