2000 v70xc 2.4T idle problem/power problem *long*

  #1  
Old 01-24-2019, 08:38 PM
Junior Member
Thread Starter
Join Date: Oct 2016
Posts: 9
Default 2000 v70xc 2.4T idle problem/power problem *long*

I have owned the car a little over a year and have put 12k or so miles on it. I do almost all of my own maintenance/repairs. The MAP sensor failed in April 2018 and caused a no start condition, and I replaced it with no issues. The ETS light came on in October and went off, came on again intermittently with no real symptoms of the ETM failure these year models are known for but I replaced the ETM proactively in early November with a rebuilt ETM that had the Sacer contactless upgrade done. The unit I bought was a reman from a turbo Volvo, and the replacement went fine with no issues and the ETM light was no longer coming on- no reprogramming was done nor did it seem to need any. The car ran fine for over a month or more. In late December the car then started idling rough and would go into limp mode or would not go above about 2k RPM unless the MAF sensor was unplugged. When it was unplugged the car ran pretty normally but the idle was still a problem and would also stall at idle occasionally. No codes unless the MAF was unplugged then got a code for MAF signal. Testing and research indicated a possible ETM problem even though there was no ETS code that I could find with my generic OBD scanner. I diagnosed a problem with the power supply to the ETM not supplying 12v- that power wire has a known issue for developing a short and failing to provide voltage. I spliced in a replacement wire and confirmed voltage to the ETM and that it was powering on properly when the ignition was turned on. Now the car would attempt to run and would immediately die and of course could not be driven. Is this something you might be able to help with?

Thanks for your time, sorry for writing a short novel.
 
  #2  
Old 03-25-2019, 08:15 PM
Junior Member
Thread Starter
Join Date: Oct 2016
Posts: 9
Default

to all who may be interested the ETM *had* broken and a replacement used one was also bad. A new ETM and a software reload has everything sorted out fine.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CasperNJ
Volvo S40
3
05-10-2014 01:12 PM
Scoobob
1998-2000 model year V70
1
12-13-2013 08:19 AM
jklenk
Volvo V70
2
08-18-2008 12:26 AM
ariston18
Volvo S40
6
04-10-2007 05:59 PM
Robert Angell
Volvo XC70
5
01-31-2006 07:50 AM


Thread Tools
Search this Thread
Quick Reply: 2000 v70xc 2.4T idle problem/power problem *long*


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.