Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo XC70 > 2001-2013 model year XC70
Reload this Page >

Grinding noise 3.2 XC70 2008 decelerating when cold from front right

Grinding noise 3.2 XC70 2008 decelerating when cold from front right

  #1  
Old 08-12-2013, 09:48 PM
Junior Member
Thread Starter
Join Date: Aug 2013
Posts: 2
Default Grinding noise 3.2 XC70 2008 decelerating when cold from front right

I need some help. My mechanic and I are having real trouble figuring this one out. I have a 2008 XC70 3.2 petrol automatic. When it is cold it makes a very audible grinding sound that you can feel resonating from the front right hand corner of the car. It happens when turning corners (particularly right) and during deceleration. If I select a low gear to compression brake it is most audible and sounds disgusting! As the car warms up over a period of around fifteen minutes it goes away. Engine mounts "seem" to be ok and it has a new top roll mount. We cant find any heat shields rubbing. All fluid levels are ok. All suspension components seem good too. The trans shifts nicely and the car has only done 64000km. We are frustrated and would really appreciate any solutions. I have read of others with similar issues but nobody has posted a fix. YET!!
 
  #2  
Old 09-04-2013, 08:57 AM
Junior Member
Join Date: Mar 2011
Posts: 9
Default Buzzing noise during deceleration

I have a 2008 xc90 I6 and have just noticed a buzzing mechanical sound coming from the drivers side front. It is RPM relative, and most noticeable when decelerating, but also noticeable when accelerating.
This morning was cooler, and after about 30 minutes of driving in stop and go traffic, it just as quickly went away.
Since it is related to engine speed, there may be some connection to the serpentine belt and related components. It would seem to me that a transmission related problem that would cause that type of noise would not quickly stop.
 
  #3  
Old 10-15-2013, 12:41 PM
Junior Member
Join Date: Oct 2013
Posts: 2
Default

Originally Posted by XC70AA View Post
I need some help. My mechanic and I are having real trouble figuring this one out. I have a 2008 XC70 3.2 petrol automatic. When it is cold it makes a very audible grinding sound that you can feel resonating from the front right hand corner of the car. It happens when turning corners (particularly right) and during deceleration. If I select a low gear to compression brake it is most audible and sounds disgusting! As the car warms up over a period of around fifteen minutes it goes away. Engine mounts "seem" to be ok and it has a new top roll mount. We cant find any heat shields rubbing. All fluid levels are ok. All suspension components seem good too. The trans shifts nicely and the car has only done 64000km. We are frustrated and would really appreciate any solutions. I have read of others with similar issues but nobody has posted a fix. YET!!
Hi,
I'm having the EXACT same issue with my '08 XC70. I have an appt with the dealer next week. Were you able to find out what the problem was?
 
  #4  
Old 10-15-2013, 05:43 PM
Junior Member
Thread Starter
Join Date: Aug 2013
Posts: 2
Default

[QUOTE=XC70AA;362233]I need some help. My mechanic and I are having real trouble figuring this one out. I have a 2008 XC70 3.2 petrol automatic. When it is cold it makes a very audible grinding sound that you can feel resonating from the front right hand corner of the car. It happens when turning corners (particularly right) and during deceleration. If I select a low gear to compression brake it is most audible and sounds disgusting! As the car warms up over a period of around fifteen minutes it goes away. Engine mounts "seem" to be ok and it has a new top roll mount. We cant find any heat shields rubbing. All fluid levels are ok. All suspension components seem good too. The trans shifts nicely and the car has only done 64000km. We are frustrated and would really appreciate any solutions. I have read of others with similar issues but nobody has posted a fix. YET!![/QUOTE

solved!!

It was a broken engine mount on right hand side of motor. The mount seemed alright when loaded in drive and reverse but we got desperate and removed it as a thorough process of elimination. We found that it was in fact broken and the mounting bolt could be moved freely in one direction which it should not be able to do. Easy fix
 
  #5  
Old 10-16-2013, 10:15 AM
Junior Member
Join Date: Oct 2013
Posts: 2
Default

Great! I'm glad to hear that it's an easy fix. Thank you SO much for getting back to me!
 
  #6  
Old 04-19-2016, 03:37 PM
Junior Member
Join Date: Apr 2016
Posts: 1
Default

[QUOTE=XC70AA;368669]
Originally Posted by XC70AA View Post
I need some help. My mechanic and I are having real trouble figuring this one out. I have a 2008 XC70 3.2 petrol automatic. When it is cold it makes a very audible grinding sound that you can feel resonating from the front right hand corner of the car. It happens when turning corners (particularly right) and during deceleration. If I select a low gear to compression brake it is most audible and sounds disgusting! As the car warms up over a period of around fifteen minutes it goes away. Engine mounts "seem" to be ok and it has a new top roll mount. We cant find any heat shields rubbing. All fluid levels are ok. All suspension components seem good too. The trans shifts nicely and the car has only done 64000km. We are frustrated and would really appreciate any solutions. I have read of others with similar issues but nobody has posted a fix. YET!![/QUOTE

solved!!

It was a broken engine mount on right hand side of motor. The mount seemed alright when loaded in drive and reverse but we got desperate and removed it as a thorough process of elimination. We found that it was in fact broken and the mounting bolt could be moved freely in one direction which it should not be able to do. Easy fix
Hi there, just had this problem on my volvo v70 3.2 this morning. Could you post a picture the mount or part number. And was the mount on the right hand side when your sitting in the car. Thank you.
 
  #7  
Old 08-26-2018, 05:52 PM
Junior Member
Join Date: Feb 2018
Posts: 2
Default Same

So I'm having the same noise, it is getting worse (2008 xc70 144k) I replaced the bottom mount it was visibly worn. Struts are in need of replacement, the noise is apparent when going over dips in the road, when in reverse, and when turning right. Sometimes it goes away after driving 20 miles or so. What else should I be looking for?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
georgiedm
Volvo XC90
2
04-04-2015 03:46 AM
Wing0
Volvo XC90
4
12-13-2013 02:39 PM
lcocke
Volvo V70
1
06-21-2013 08:32 PM
yert315
Volvo XC90
1
05-26-2012 06:04 PM
gerbs
Volvo 240, 740 & 940
6
04-29-2007 09:32 PM


Thread Tools
Search this Thread
Quick Reply: Grinding noise 3.2 XC70 2008 decelerating when cold from front right


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.