General Volvo Chat Post Your Questions And Comments on any of Volvo's many models.

V70 Electrics going haywire !!

  #1  
Old 05-22-2018, 03:18 AM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 2
Default V70 Electrics going haywire !!

Hi, I have a 2004 V70 Automatic. 100,000miles and looks and drives absolutely as new . . . . . . . until, after doing around a 50 mile run the electrics go wierd. It starts by jerking a couple of times ( which I saw in the reflection on the car in front was the headlights going off and on ) Then the speedo array went totally blank, the wipers stopped working, no indicators, windows stopped working and when I stopped and set off again it was so sluggish as if in safe mode but once built up speed drove Ok at 70mph to get home ( still no indicators etc. ) When I did stop there were various clicks and buzzes from behind the dash and in the engine compartment. At home the central locking didn't work, but a few hours later everything working fine !! Done this once again, so only done short journeys, but the other day when the weather was really hot did same again after only 7 miles. Any suggestions as I have had to hire a car to go to a funeral as not sure if would get me there. Many thanks
 
  #2  
Old 05-22-2018, 11:53 AM
Senior Member
Join Date: May 2012
Location: Kingsport, TN
Posts: 1,507
  #3  
Old 05-22-2018, 12:02 PM
Senior Member
Join Date: May 2012
Location: Kingsport, TN
Posts: 1,507
Default

Here are some people who fixed it well and thoroughly, if it's the same issue
P2 Owners: XeMODex now fixes CEM & REM before they fail
 
  #4  
Old 05-22-2018, 01:23 PM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 2
Default

Thanks ever so much for that Firebird. It seems as if that is likely to be the problem. I did think it was perhaps due to something overheating but hadn't got a clue what. I will have a go at getting a fan and then go on a long run. Thanks again. Will post how I get on.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
blazing17
Volvo S80
0
10-01-2011 06:48 PM
anneVA
Volvo XC90
3
07-05-2010 11:57 AM
98T5
Volvo V70
1
10-28-2009 08:03 PM
rfrazier
Volvo S40
0
06-14-2009 01:20 PM
bjornagain
Volvo V70
1
08-05-2008 07:43 PM


Thread Tools
Search this Thread
Quick Reply: V70 Electrics going haywire !!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.