New Members Area Just Joined? Be sure to pop in here and introduce yourself.

2012 Volvo S60, bad motor mounts?

  #1  
Old 08-24-2018, 08:29 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default 2012 Volvo S60, bad motor mounts?

Hello everyone. I am trying to figure out if I have bad motor mounts or if this is a different problem. When I brake, the best way I can describe it is that the car grabs or jumps and will sometimes even move me in my seat an inch or so! Sometimes if I put it in park then back in drive it will stop. It doesn't do this when I accelerate ever, only brake. I have seen videos showing that if motor mounts are bad that the engine will move or jump. I took a video of my car tonight and the engine definitely lifted in the front when I put it into drive, then reverse then back to drive but not when it was in park and I revved the engine. I'm curious if anyone thinks this is motor mounts or something else? Thanks in advance!
 
  #2  
Old 08-30-2018, 03:01 PM
Member
Join Date: Jul 2018
Posts: 87
Default

The engine is mounted in BIG soft rubber mounts. It moves around a lot normally. If the car is jerking when you apply the brakes, there must be something wrong with the brakes.

This is a LARGE potential safety concern. I'd suggest you take it to an expert right now before something bad happens. Need to keep you safe.
 
  #3  
Old 08-30-2018, 06:45 PM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default

hThank you for this reply. I actually traded my car in for a Ford Fusion this weekend. I couldn't take another repair or safety risk with that Volvo. Thank you for your advice!
 
  #4  
Old 08-31-2018, 10:38 AM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,678
Default

sounds like somebody is getting a good deal on a Volvo that just needs some brake pads or perhaps a vacuum pump repair...Not sure why you didn't simply have a shop look at the car.
 
  #5  
Old 09-01-2018, 09:18 AM
Junior Member
Thread Starter
Join Date: Aug 2018
Posts: 3
Default

I actually did but I wasn't convinced motor mounts were the answer. Brakes were done 6 months ago and rotors were fine, had the brakes checked AGAIN thinking it must be a brake problem, he said no that it was motor mounts. Car left me SIT in the middle of the road three times in 2 years, I was over it!
Thanks for the reply tho
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
netdvn
Volvo S60 & V60
7
09-27-2015 10:03 AM
New Members Area
0
08-17-2014 12:32 PM
blackguy_with_volvo
Volvo S60 & V60
2
04-24-2014 04:00 AM
JasnAl
Volvo 240, 740 & 940
2
08-10-2013 06:17 PM
proudmonkey
Volvo 240, 740 & 940
1
05-20-2005 01:57 PM


Thread Tools
Search this Thread
Quick Reply: 2012 Volvo S60, bad motor mounts?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.