North East ME, NH, VT, MA, RI, CT, NJ, NY, PA

engine running rough.....

  #1  
Old 08-16-2010, 12:41 PM
Junior Member
Thread Starter
Join Date: Dec 2009
Posts: 7
Default engine running rough.....

Spitting and sputtering, changed fuel filter and air filter. Two cans of injector cleaner later it seemed to work itself out. 400 miles later I am back to the same problem. Pretty sure its a sensor but am unsure where to start, any help would be greatly appreciated.
 
  #2  
Old 08-16-2010, 12:43 PM
Junior Member
Thread Starter
Join Date: Dec 2009
Posts: 7
Default

This is a 1987 740 Turbo
 
  #3  
Old 08-18-2010, 09:48 PM
Junior Member
Join Date: Jul 2010
Posts: 10
Default

Originally Posted by guysmilee View Post
This is a 1987 740 Turbo

Its either a Mass air flow sensor issue or a fuel pump is not keeping up the flow and causing it to run rough...I had a 740 regina system and it was running rough and missing etc...ended up being the fuel pump was flowing enough to keep the car running at idle, but give it gas and it would stumble and run crappy. Changed the fuel pump, and ran like a champ
 
  #4  
Old 08-29-2010, 08:24 PM
Join Date: Aug 2010
Posts: 44
Default

could also be a stuck egr valve or loose intercooler connection... my 2 cents.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tina2222
Volvo S80
4
11-15-2014 10:06 PM
garysvolvo
Volvo S70
6
08-14-2012 04:21 PM
tjohnson05
Volvo 240, 740 & 940
3
03-23-2010 09:32 PM
Carbuff
Volvo 240, 740 & 940
7
11-29-2005 09:30 PM
duffdr
Volvo S40
1
04-12-2005 01:51 AM


Thread Tools
Search this Thread
Quick Reply: engine running rough.....


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.