Off Topic A place for you car junkies to boldly post off topic. Anything Goes.

Tried to help a guy with a Ford Ranger

  #1  
Old 06-06-2012, 07:28 AM
rspi's Avatar
Administrator
Thread Starter
Join Date: Mar 2009
Location: Albuquerque, NM
Posts: 15,762
Default Tried to help a guy with a Ford Ranger

Got a call from a friend of a friend yesterday, his '99 Ford Ranger broke down near his job. Went and immediately hooked up the scanner which gave a P0340 Camshaft Sensor Fault code. I immediately told him that we needed to get a new sensor and that SHOULD do it. Upon return to the truck which is a 4 cylinder with 8 plugs (go figure), the sensor was easy to replace once I found it. Things were just going to easy. I told him to crank it and it still did not start.

I looked around and decided to put my finger behind the timing belt cover and feel the belt, yes it was loose as a goose. Looks like the belt was never changed and the truck has 167,000 miles on it.

I threw in the towel at that time. The shop I had them call claims that the motor is NOT an interfierance type so they might be ok.

Just a note, a CPS fault code may not be a bad sensor code. LOL
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
nellers1988
General Volvo Chat
3
10-19-2011 12:34 PM
Keith Tobberman
General Volvo Chat
5
11-20-2007 07:01 PM
jguerra3235
Volvo 240, 740 & 940
2
03-25-2007 10:20 AM
JetTech
Volvo 240, 740 & 940
0
12-20-2006 11:08 AM


Thread Tools
Search this Thread
Quick Reply: Tried to help a guy with a Ford Ranger


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.