Penta Discuss Volvo Penta Marine Machines Within.

2003 8.1 stall when starting

  #1  
Old 01-23-2019, 06:32 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Default 2003 8.1 stall when starting

I have an issue with my 2003 Formula with 8.1s . When I start them ( cold ) the port engine stalls unless I run the rpms to 800-1000. And let it run for a while . Then once warm , she runs like a champ. I cleaned the spark arrestor, changes the plugs ( they looked fine but put new in anyways). Im wondering if the MAP sensor needs replacing?
 
  #2  
Old 01-26-2019, 01:40 PM
Moderator
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 4,421
Default

Why would you think the MAP sensor needs replacing? Did you measure the resistance of the engine coolant temp sensor?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jwandhistools
Volvo 240, 740 & 940
2
08-11-2009 09:43 AM
nadernur
Volvo 240, 740 & 940
5
08-08-2006 02:09 PM
Red XC
Volvo 850
12
05-09-2006 12:07 AM
wild wane
Volvo 240, 740 & 940
5
04-19-2006 10:11 PM
tomservo
Volvo 850
1
04-14-2006 09:37 PM


Thread Tools
Search this Thread
Quick Reply: 2003 8.1 stall when starting


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.