My 90í 240 DL instrument Pannel went out.

  #1  
Old 06-19-2019, 11:42 AM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default My 90í 240 DL instrument Pannel went out.


My instrument cluster went out about 2-3 days ago. All the gauges do not work except for the clock. But the light **** on the left works for turning on my car lights and so does my radio. So I replaced all the fuses that I thought might be bad and that deal with the instrument cluster and with what fuses I had on me. It still will not work, what can I do to fix it, what might be the problem? Also are all the fuses that I have in the correct spot?
Red fuse: 16A
Blue fuse: 25A
White fuse: 8A
 

Last edited by Chynabell13; 06-19-2019 at 02:04 PM.
  #2  
Old 06-19-2019, 03:38 PM
Former Moderator
Join Date: Oct 2010
Location: 37 North on the left coast
Posts: 10,000
Default

the fuse panel cover should have a list of the fuses for your car, and what size goes where. I don't remember the 240 having that many red ones, I think there were more whites, but I could be wrong, its been years since my 240 went off to college with my girl and eventually got scrapped for getting too moldy inside due to water leaks

ok, looking in the wiring diagrams for a 1990, I see.....

1 - 8A - cigar lighter, tailgate wiper, power mirros, radio, antenna
2 - 16A - windshield wiper, horn, headlamp wiper
3 - 25A - heater fan
4 - 8A - in-tank pump, Oxy sensor (lambda) preheater
5 - 16A - turn signals, reverse lights
6 - 16A - ? not used in LH2.4 ?
7 - 8A - brake lights
8 - 8A - clock, courtesy lighting, trunk light, central locking, , radio always-on power
9 - 8A - hazard lights
10 - 16A - power windows
11 - 16A - overdrive, heated rear window
12 - 8A - seat belt reminder, power window relay, air conditioning
13 - 16A - heated seats
14 - 8A - rear fog lamp, switch(?)
15 - 8A - left parking/tail lights, license plate light
16 - 8A - right parking/tail lights, instrument lighting, indicator lamp.


fuses 1-2-3 are powered when the key is in I or II (accessory or run)
fuses 6-7-8-9-10 are always powered
fuses 11-12-13 are powered in II (run) only.
others are parts of various circults
 
  #3  
Old 06-19-2019, 04:57 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default


This is how they are now.

And now my check engine light is on..
I believe I had put in the wrong fuses for my fuse box because when I went to orilleys to get a couple more of the white fuses and I had already replaced most of them with the lower fuse and my car shut off while I was leaving. And wouldnít start unless I put the red ones back in.
 

Last edited by Chynabell13; 06-19-2019 at 04:59 PM.
  #4  
Old 06-19-2019, 05:14 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default My engine is running hot now too.


The coolant is full..

So now that I have changed the fuses even with the coolant filled to the top my car is over heating you can feel it itís hot..?
 

Last edited by Chynabell13; 06-19-2019 at 05:18 PM.
  #5  
Old 06-19-2019, 06:03 PM
Senior Member
Join Date: Sep 2012
Posts: 247
Default

Are you going by your temp guage? What happens exactly?

As for your CEL, try using the on board diagnostics computer and read the code.
 
  #6  
Old 06-19-2019, 06:06 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default

Ever since I had changed the fuses before to the wrong ones The engine feels hot to the touch as well as the temp gauge is high..
How do I read the code? Iím sorry Iím new to all of this really.
 
  #7  
Old 06-19-2019, 06:18 PM
Senior Member
Join Date: Sep 2012
Posts: 247
Default

Originally Posted by Chynabell13 View Post
Ever since I had changed the fuses before to the wrong ones The engine feels hot to the touch as well as the temp gauge is high..
How do I read the code? Iím sorry Iím new to all of this really.
How to read codes:
How to read the engine codes on 1990-1993 Volvo 240

As for the over heating, its either the water pump (common) or the temperature gauge compensator board is giving false readings. Does the gauge immediately shoot up when you star the car?
 
  #8  
Old 06-19-2019, 06:21 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default

No, it doesnít shoot straight up it gradually goes up. the car feels hot to the touch and the coolant is filled to the top. So it is definitely over heating. And it only started to do that when I put the wrong fuses in the wrong places.. as well as for the check engine light...
 
  #9  
Old 06-19-2019, 06:49 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default So here is a video of the codes that are reading off my car..

Can someone read these for me? So here is a video of the codes that are reading off my car..https://share.icloud.com/photos/0PPZ...JF4IR2zgw#Home
 

Last edited by Chynabell13; 06-19-2019 at 08:25 PM.
  #10  
Old 06-19-2019, 07:00 PM
Senior Member
Join Date: Sep 2012
Posts: 247
Default

Originally Posted by Chynabell13 View Post
No, it doesnít shoot straight up it gradually goes up. the car feels hot to the touch and the coolant is filled to the top. So it is definitely over heating. And it only started to do that when I put the wrong fuses in the wrong places.....
That bit just confuses me, since the water pump and fan are mechanically driven, I dunno what the issue is.
 
  #11  
Old 06-19-2019, 07:06 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default

Let me know if you are able to see the video.
 
  #12  
Old 06-19-2019, 07:12 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default

And here is a video of my temperature gauge slowly going up.. https://share.icloud.com/photos/0bAN...4rypvFCsQ#Home
 
  #13  
Old 06-19-2019, 07:19 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default So this is the main issue here. Is my check engine light being on.


So this is the temperature gauge when my car is on and just sitting.
So this is the main issue here. Is my check engine light being on considering my temperature gauge seems fine while my car is just sitting
 
  #14  
Old 06-19-2019, 07:25 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default


And here is a picture of the gauge now that I have driven it around the block?
 
  #15  
Old 06-19-2019, 07:31 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default Here is a video of my temperature gauge going up as I drive.

  #16  
Old 06-19-2019, 08:11 PM
Senior Member
Join Date: Jan 2011
Location: New York
Posts: 1,045
Default

Is the coolant boiling out of the pressure cap on the tank. If it isn't then you have a gauge problem.
 
  #17  
Old 06-19-2019, 08:14 PM
Junior Member
Thread Starter
Join Date: Jun 2019
Posts: 15
Default

No it isnít but it does feel VERY hot. And I donít want to drive around with it getting hotter considering I could really ruin my car if it really over heated.
 
  #18  
Old 06-19-2019, 08:23 PM
Senior Member
Join Date: Sep 2012
Posts: 247
Default

Your engine code is "2-3-1 – Lambda control – too lean or too rich at part load", check your vacuum hoses and the throttle body. As for the overheating, does that happen with the AC on or just regular driving?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
itsmesunny
Volvo 240, 740 & 940
16
11-11-2013 06:31 PM
berrymcb
Volvo S60 & V60
0
12-07-2011 10:48 AM
sharkdude
Volvo S60 & V60
1
08-21-2010 03:52 PM
htoad
Volvo 240, 740 & 940
0
11-02-2008 10:25 PM
Alexander
Volvo 240, 740 & 940
3
06-28-2005 10:33 PM


Thread Tools
Search this Thread
Quick Reply: My 90í 240 DL instrument Pannel went out.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.