760 ran great for month and now it won't stay running - Volvo Forums - Volvo Enthusiasts Forum


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-13-2018, 07:55 AM
Junior Member
Thread Starter
 
Join Date: Jun 2018
Location: Fresno Ca
Posts: 2
Default 760 ran great for month and now it won't stay running

My girl bought this 1989 760 turbo for $150 and it ran great for about 6 months and then started having trouble with starting after putting gas or a trip to the store. After a couple of months of trying to diagnose the problem we're told that it could be the crankshaft position sensor. No one could tell us where it was on the car. Then a guy told us to check the fuel pump relay. We replaced that and yeah it started. Ran great for a month then it died on her on the way home. Now it will start but won't stay running. Any suggestions? Oh yeah! Before it died, it was on a small incline and while accelerating it just started losing power once she got up to 60 mph. There was a vacuum hose that was off but it was put back on

Last edited by [email protected]; 06-13-2018 at 08:03 AM. Reason: Forgot to mention that it just lost power before it died on her
Reply With Quote
  #2  
Old 06-13-2018, 04:35 PM
Senior Member
 
Join Date: Nov 2006
Location: Birmingham AL
Posts: 664
Default

There are dozens of issues here that are possible. Guessing will cost more in parts than having a diagnosis.

A car that old does have wiring issues in that the insulation on the wiring harness is probably gone and creating shorts to ground or power.

I do not think that anyone makes replacement harnesses so if that is the issue, time to get creative or junk the car.
Reply With Quote
  #3  
Old 06-13-2018, 11:24 PM
lev lev is offline
Senior Member
 
Join Date: Oct 2010
Posts: 2,926
Default

"Dozens"? No. Check Eng. Light on? This car should have OBD1 (on board diagnostics) by the left strut tower. Run the codes. Wiring is not usually an issue on '89s. May have a fuel pump problem, MAFS acting up, not too many things that can be wrong...
Reply With Quote
  #4  
Old 06-17-2018, 04:41 AM
Junior Member
Thread Starter
 
Join Date: Jun 2018
Location: Fresno Ca
Posts: 2
Default

Quote:
Originally Posted by lev View Post
"Dozens"? No. Check Eng. Light on? This car should have OBD1 (on board diagnostics) by the left strut tower. Run the codes. Wiring is not usually an issue on '89s. May have a fuel pump problem, MAFS acting up, not too many things that can be wrong...
Thank you for the suggestion. I hope this works because my girl really likes the car.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 V70 XC Turbo Stalled and won't stay running Josh Decker 2001-2013 model year XC70 1 10-23-2017 11:49 AM
Ran Out Of Gas Now Won't Start Salty Dog General Volvo Chat 3 02-13-2017 10:11 AM
Ran for about half an hour after fresh headgasket shut it off now it won't start Johnathan Babcock Volvo 850 4 01-12-2017 05:26 PM
Ran Great, then Died. Need help finding part. Bumblebeeman Volvo 240, 740 & 940 17 09-27-2012 02:55 AM
240 no start ran great now dead chrismears Volvo 240, 740 & 940 1 02-19-2006 11:38 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 05:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.