Volvo C70 This sporty coupe has a three-piece retractable hardtop for unsurpassed fun whether the the top is up or down.

Hardtop stuck partially open

  #1  
Old 03-27-2017, 12:12 PM
Junior Member
Thread Starter
Join Date: Dec 2014
Posts: 5
Default Hardtop stuck partially open

I stopped the opening of the top partially opened in order to glue the headliner. Now it does not move. I tried the procedure in the manual of holding either button down for a minute and I also tried disconnecting the battery. Here are the messages and the results of the scanner. Any suggestions would be appreciated:

Messages
After starting engine = “roof not locked”
After pushing up or down button = “roof failure see manual”
After holding down button for 30 seconds = “roof failure service required”

Scanner , CRM - convertible roof module
Read DTC = no DTCs
Read Datastream
Hydraulic pump temp = low
Hydraulic pump = stopped
Valve 1 =closed
Valve 2 = closed
Valve 3 = closed
Valve 4 = closed
Catch motor = unlocked
Supply voltage = 14.1
Button open roof = button not pressed (while pushing button = button pressed)
Button close roof = button not pressed (while pushing button = button pressed)
Button load aid = button not pressed
Auto up window lifts = normal operation
Messages in DIM = 14 (when pressing either button = 13)
Position = roof opening preparations (when pressing either button = no match)
Head lamp washer = normal operation (when either button pushed = inhibited)
Speed limitations km/h = 2 km/h
Speed limitations mph = 1.24 mph
Ambient temp = 27
Hall sensor 1 = passive
Hall sensor 5 = passive
Hall sensor 3 = passive
Hall sensor 6 = passive
Hall sensor 7 = passive
Hall sensor 19 = passive
Hall sensor 9 = passive
Hall sensor 20 = Active
Hall sensor 11 = passive
Hall sensor 12 = Active
Hall sensor 13 = passive
Hall sensor 18 = Active
Hall sensor 15 = passive
Hall sensor 16 = Active
Position encoder2, rear roof = intermediate 1
Position encoder 17, front roof = intermediate 2
No. of roof manoeuverings = 417
No. of electrical overrides = 7
 
  #2  
Old 03-28-2017, 10:18 AM
Junior Member
Thread Starter
Join Date: Dec 2014
Posts: 5
Default Fixed

FYI - I got it working again. I tried to jog the CRM brain by driving it a few feet until the warning chime started. But that did not do anything. Then I reached into the trunk and loosened the plastic divider. I started the engine and pushed the down button. The message about a loose divider appeared. I reached back into the trunk and closed the divider. Then I hit the down button. It started moving but only about halfway down. Then I hit the other button and it closed all the way. Then I hit the other button and it went all the way down this time.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
londe
Volvo 260, 760 & 960
5
03-03-2019 07:19 PM
londe
All Other Volvo's
2
03-27-2011 01:36 PM
tasiasnow
Volvo S40
1
03-09-2011 04:24 PM
myGFsVolvo
Volvo S40
6
11-04-2010 10:36 PM


Thread Tools
Search this Thread
Quick Reply: Hardtop stuck partially open


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.