Dashboard screen problems after 60k service - Volvo Forums - Volvo Enthusiasts Forum

Go Back  Volvo Forums - Volvo Enthusiasts Forum > Volvo Vehicles > Volvo S60 & V60
Reload this Page >

Dashboard screen problems after 60k service

Volvo S60 & V60 The mid level Volvo sedan and wagon that offer power, performance and an exciting ride.

Dashboard screen problems after 60k service

Reply

 
 
 
  #1  
Old 10-08-2018, 07:40 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Location: Michigan
Posts: 3
Default Dashboard screen problems after 60k service

Hello. I have a 2015 V60 that is just about to hit 60k miles. I have a 1700mi road trip coming up and so I scheduled my 60k service with my local "European specialty" mechanics. All went well but when I got the car back the dash screen stuff is all out of sorts. I can get into the "My Car" section, but all the audio, clock etc... functions will not work. If I get it to turn on, the menu pops up, but if you scroll through to individual sections, nothing works.


The mechanic had the car back for a few hours today and they seemed to rule out anything they might have done during the 60k mile service as the root of the problem. Of course. Sometimes a coincidence is just that, but I'm loathe to spend money on exploring a problem that didn't exist when I brought the dumb thing into them in the first place.


Does anyone else have this problem or have an idea what might be done to correct it? I'm quickly starting to despise this vehicle. I like the fuel economy and the smoothness of the ride, but I get frequent check engine codes for "lean fuel system" when the weather changes or I run the tank too low on a highway trip.
 
Reply With Quote
  #2  
Old 10-08-2018, 08:27 PM
Senior Member
Join Date: Oct 2010
Posts: 4,899
Default

A 60k service (or any service, for that matter) has nothing to do with problems from the center screen.

And the weather isn't causing your check engine light. There is a problem that needs to be diagnosed .
 
Reply With Quote
  #3  
Old 10-08-2018, 10:32 PM
Junior Member
Thread Starter
Join Date: Oct 2018
Location: Michigan
Posts: 3
Default

Well, I guess it's a coincidence then. It just seems quite odd that it would happen immediately after I turned the vehicle on after having had the car in for service.
 
Reply With Quote
  #4  
Old 10-08-2018, 11:32 PM
Senior Member
Join Date: Oct 2010
Posts: 4,899
Default

A 60k is only an oil change and cabin filter replacement.
 
Reply With Quote
  #5  
Old 10-09-2018, 12:44 AM
Junior Member
Thread Starter
Join Date: Oct 2018
Location: Michigan
Posts: 3
Default

I was told (and paid for) a lot more than that on the 60K service. I've read that what you suggest is all that is necessary...but I've also read where a lot more is necessary. Shame on me for believing my mechanic...but I certainly am not someone with the time or knowledge to do these things myself. Again, shame on me.

I guess my question is still out there... As it isn't the 60K service, what would cause many of the dashboard screen functions (radio, clock, Bluetooth, CD etc...) to suddenly stop working when they worked fully when I dropped the car off that morning? The only thing that will display on the screen and still work is the "My Car" function which allows the "Sport" mode. This will make for optimum handling when I drive this expensive piece of garbage into the nearest lake. Kidding. Kind of.

Is is it fuses? Software issue? Something disconnected and not reconnected properly? Is it in the possession of demons? What would make a previously functioning system stop working like this? Has no one encountered this?
 
Reply With Quote
  #6  
Old 10-09-2018, 07:22 AM
Senior Member
Join Date: Oct 2010
Posts: 4,899
Default

All services are outlined in the maintenance manual for the car. Goes to show you that just because a repair shop isn't a dealership doesn't mean they are honest.

I haven't encountered that problem yet. You'll probably need to take it to the dealer to see what codes are stored.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
charley9
Volvo S60 & V60
0
03-13-2010 11:14 AM
Tacodog
Volvo S60 & V60
1
05-09-2008 11:38 PM
MattS77
Volvo S40
3
01-22-2008 07:27 AM
tcrossley
Volvo S40
6
01-21-2007 07:37 PM
gordon368
Volvo S80
3
11-18-2005 12:54 AM


Thread Tools
Search this Thread
Quick Reply: Dashboard screen problems after 60k service


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.