Volvo S70 Made from 1998 to 2000, this sporty model replaced the 850 sedan and instantly became a hit.

alarm defect?

  #1  
Old 08-17-2017, 05:11 PM
PKL
PKL is offline
Junior Member
Thread Starter
Join Date: Apr 2011
Posts: 4
Red face alarm defect?

Hello again everyone. Been a while since I've been here. Hope everyone has been well. I have a confusing problem. While driving my 1998 S70 GLT I heard a soft or muffled pop come from the dash. The car immediately felt like it was going to die and just as quickly surged back to life. I also noticed 5 or 6 indicator lights that came on but went off too quickly to identify. The anti-theft light on the radio came on and stayed on and the radio will not play. This happened 3 times that I'm aware of over the course of 2 days. I parked the car yesterday. I noticed the doors were not locked today. I tried the key fob and nothing happened. I got in the car and tried turning it on with the key and had absolutely no response whatsoever. The small red indicator light on the dash that usually blinks when the alarm is engaged has also gone off. The only thing I can think of is something in the alarm system is telling my little car that it's been stolen and my car is absolutely dead. Does anyone have any suggestions? Thanks for your time guys, hope you have a good day.
 
  #2  
Old 08-18-2017, 10:21 AM
Senior Member
Join Date: May 2012
Location: Kingsport, TN
Posts: 1,513
Default

Sounds more like you have no electrical power. The battery could be totally dead, but given the symptoms, I think it's more likely that you just have a corroded connection to the battery.
 
  #3  
Old 08-21-2017, 06:22 PM
PKL
PKL is offline
Junior Member
Thread Starter
Join Date: Apr 2011
Posts: 4
Default

Thanks for the input firebirdparts. I agree it's an electrical problem. I put a new battery in my fob just out of curiosity. The doors unlocked, I got in, started the car, surprisingly, and noticed after I shut it off that the flashing indicator alarm light on the dash still isn't lighting up. The fob worked 1 time after putting a new battery in it but now I get nothing from it. The car will run, terribly, but I think that is another issue. If I unhook / bypass the alarm system will the car run at all? Just wondering. Thank you for your response. Have a good day.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
darylabrams
Volvo V70
0
12-25-2010 06:53 PM
holobox
Volvo S90 & V90
6
09-11-2009 07:35 AM
BuildinAs70
Volvo S70
4
01-02-2008 06:21 PM
2008XC90
Volvo XC90
2
07-26-2007 02:37 PM
trehux
New Members Area
0
08-10-2004 07:01 PM


Thread Tools
Search this Thread
Quick Reply: alarm defect?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.